FLDigi 4.1.14 and Mac help needed

Discussion in 'Mac Ham Radio on macOS & iOS' started by WB9JPH, Jul 17, 2020.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: L-MFJ
ad: abrind-2
ad: Left-3
ad: Left-2
  1. WB9JPH

    WB9JPH Premium Subscriber QRZ Page

    I have a mac mini running OS 10.15.6. FLDigi 4.1.14, & FLRig 1.3.50.

    Both programs run and appear to work. FLRig works like a charm but while FLDigi runs, it is stone deaf.

    The correct silicon lab drivers are installed on the mac.

    MLDX, JS8 Call and WSJT-X all work like a charm.

    Audio input source (USB Codec) is the same on all software packages.

    What have I missed?
     
  2. DL2RUM

    DL2RUM Ham Member QRZ Page

    Why do you want to run both at the same time? Only one app can control the TRX. Then you have to configure Fldigi as client for Flrig.
     
  3. WB9JPH

    WB9JPH Premium Subscriber QRZ Page

    I only run the FLRig & FLDigi by themselves.. FLRig controls FLDigi just fine but FLDigi gets no audio input.

    I mention the other programs only to indicate that they run and in the case of wsjt-x & js8call have audio in and out.

    I reboot both the radio and computer before starting FLDigi & FLRig.
     
  4. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    You say that it's "stone deaf." How do you determine that? Have you tried changing the signal level controls in the lower left corner of the Fldigi screen? I usually set mine for -20 and a signal range of 70dB: If I recall correctly, it defaults values of 0 and 60, which means only the very strongest signals will get picked up in macOS. Also, if you have the squelch turned on (SQL), you'll need a signal that overcomes the level set by the slider on the right side of the signal level. I almost never run with SQL on. See the following picture for the various controls I'm talking about.

    Capture.JPG
     
  5. WB9JPH

    WB9JPH Premium Subscriber QRZ Page

    I have changed my settings to match yours and FLDigi is still stone deaf. If I go to the mac's sound tab I can see USB Codec selected as the input source and the volume moves with the CW I am listening to, but nothing on the FLDigi waterfall..
     
  6. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    I presume that you have a checkmark in the box labeled "PortAudio" next to the USB Audio CODEC device selectors. If so, then the only other thing that I can think of is that you haven't given macOS permission to access your "microphone." Many of these programs see/treat that USB Audio CODEC as a microphone input and failing to give it access to your "microphone" will cause it to not hear a thing. Go to the Security & Privacy pane and make sure that Fldigi has access to the microphone.
     
    N6YWU and KD9CNV like this.
  7. WB9JPH

    WB9JPH Premium Subscriber QRZ Page

    EUREKA!! I did not give FLDigi microphone permissions and it now runs great.

    Thank you so very much for the info.

    TU agn es 73
    John
     
    KI4ZUQ, KD9CNV and K3DCW like this.
  8. KD9CNV

    KD9CNV Ham Member QRZ Page

    OMG! I have spent two days combing the internet in search of a solution to this problem! YOU SIR ARE A GENIUS! I have many years experience in computer and electronics technology and I would NEVER have realized the USB port would be treated as a “microphone” and require permission for the program to use “IT” that does not really exist. @#&!#@! Thank you!
     
  9. G8PMA

    G8PMA Premium Subscriber QRZ Page

    Thanks for this topic and answer - I was just setting up the apps (WSJTX, JTDX working with MacLoggerDX) and could get no input audio into the software. Gave microphone permissions and my Mac Mini M1 is now decoding like it was on steroids!
    Thanks guys
    Lindsay G8PMA
     
    KI4ZUQ likes this.
  10. KI4ZUQ

    KI4ZUQ Ham Member QRZ Page

    Your question, his answer was part of my solution! Now I have a question about what cables are you using between your computer and whatever radio you are using?
     

Share This Page