ESP32 lessons learned first day:

Discussion in 'Arduino Playground' started by AD5MB, Apr 22, 2021.

ad: L-HROutlet
ad: l-rl
ad: L-Geochron
ad: L-MFJ
ad: Left-3
ad: HRDLLC-2
ad: abrind-2
ad: Left-2
ad: MessiPaoloni-1
  1. AD5MB

    AD5MB Ham Member QRZ Page

    I bought one of these,

    [​IMG]
    [​IMG]

    mainly because it has an SMA connector, versus the second rate u.fl connectors on other boards:

    [​IMG]

    while searching for a proper pinout diagram, because that one up there from the vendor sites on Alibaba and Amazon has two errors, I stumbled across this pearl of information:

    https://www.thethingsnetwork.org/co...3_v16-on-pcb-battery-exploded-and-got-on-fire

    you can run it off the USB connector, you can run it off the battery, or you can do both and burn your house down.

    here is how you fix that:
    https://ea4eoz.blogspot.com/2019/08/fuses-in-ttgo-lora-v16.html

    I found a corrected version of that pinout. it has Xs over the errors, and the correct numbers added to the left. not the letters: 0 and 4, vs GPI00 & GPI04. The spelling of Buletooth remains unchanged.

    no program has compiled for it yet when I select board "TTGO LoRa32-OLEDV1", or any other ESP board

    next time, research first, buy later.
     
    VE3CGA likes this.
  2. AD5MB

    AD5MB Ham Member QRZ Page

    Update: I found an Arduino, as opposed to ESP32 specific, LoRaWAN gateway program that compiles. I ate a lot of grief trying to upload it until I came across this bit of information:

    many ESP modules have a button labeled EN (enable ), BOOT, or GPIO0. this is the reboot button. my module does not have one. If you push this button, it shorts GPIO0 to ground. this is the pin with the black box next to it on the mislabeled pinout above. the one above it, with the red rectangle is GPIO4, the other mistake on that pinout.

    when you upload a program to an ESP32, you:
    • press this button,
    • press reset
    • release both
    • upload
    anticipate the requirement to perform much research, or find a guru, if you get into ESP32s.
     
    W6KCS likes this.
  3. W6KCS

    W6KCS Ham Member QRZ Page

    Thanks for passing this kind of stuff along. My friends and I are just getting into these after spending a lot of time with Arduinos and will be spending a lot of time in this forum getting up to speed.
     
  4. AD5MB

    AD5MB Ham Member QRZ Page

    as of this moment, nothing works. the capacitor from ground to reset, 10 k resistor from GPIO0 to ground, holding down the reset button - nothing. I have read that you should power it up from 5V when you need to upload. If I ever get it to take an upload, I will build an uploading rig for it, for that one task.
     
  5. K6CLS

    K6CLS Ham Member QRZ Page

    looks like a good unit, if it works. I never buy off brands though, instead prefer Adafruit etc. Dunno if you just wanted LoRa, or needed the ESP32. But they dont offer that combo.
     
  6. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    sorry you're having trouble with those.
    I bought several of these: https://www.amazon.ca/KeeYees-Devel...rds=esp32&qid=1619479883&s=electronics&sr=1-4

    Its a coin toss whether or not I have to press the "load" button, somethimes not, sometines I do
    One thing about these esp32's is there is a label that comes with the package, and on the side that has the enable pin, GIOP11,
    the label should read "CMD" not "GND"
    upload_2021-4-26_19-46-30.png
    That caught me a couple times
    other than that, having good progress
     
  7. AD5MB

    AD5MB Ham Member QRZ Page

    note that all the GPIO pins are labeled GIOP above

    people say to put a 100uf cap on the EN pin to ground, put a 10K resistor between GPIO0 and ground, do the same to GPIO2, hold down various buttons in various orders, before powering up or just before the program finishes compiling - if any of these actually worked, there would not be a big long list of things to try, there would be the one that works.
     
  8. AD5MB

    AD5MB Ham Member QRZ Page

    I found a USB cable in the truck and tried that. this time it got to "Connecting....___...." and failed when it did not see a packet header. after I get back from town I get to try all the button pressing and component tricks again.
     
  9. VE3CGA

    VE3CGA XML Subscriber QRZ Page

    when my esp's do that connecting trick I have to press and hold that "IO0" button down until it starts loading, then other times it goes through one set of the ..._____ then its starts. Just when you get relaxed and it consistantly loads without the button press then it decides it wants you to prees it
    weird and almost predictable
     

Share This Page