Echolink UDP test #1 failed 10060

Discussion in 'Echolink/IRLP Tech Board' started by W6JSB, Sep 21, 2008.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Subscribe
ad: MessiPaoloni-1
ad: L-MFJ
  1. W6JSB

    W6JSB Ham Member QRZ Page

    I'm trying out EchoLink and have done the port-forwarding trick on my Firewall (WRT300N 1.1) plus the Vista firewall adjustment.

    When I do the test, I get the following

    Testing UDP
    UDP 5198 Test #1 - Receive Failed (10060)
    UDP 5199 Test #1 - Receive Failed (10060)
    UDP 5198 Test #2 - Succeeded
    UDP 5199 Test #2 - Succeeded

    Anybody know the difference between Test #1 (which fails) and Test #2 (succeeded) so I know where to start looking? I've googled around to no avail...

    Thanks,
    James

    PS. EchoLink is version 2.0.098
     
  2. WI9D

    WI9D XML Subscriber QRZ Page

    Hi did you ever get your Echolink problem resolved?

    I have the same problem except the first two work and the second two fail.

    Randy
     
  3. KD5LPB

    KD5LPB Ham Member QRZ Page

    Can you enable UPNP in Echolink? I'm not sure if it is capable. I usually just use that when running programs that require specific ports to be open. Makes things a heck of a lot easier, but less secure.
     
  4. K7TUX

    K7TUX Ham Member QRZ Page

    error code

    You need to make sure that all your ports are forwarded through your router to your pc. Once this is done, those errors will disappear.
     
  5. KC2TIK

    KC2TIK Ham Member QRZ Page

    UDP ports tests fail on Echolink firewall test

    Dear K7TUX,

    Was previously able to connect to stations on KC2TIK.

    Since I activated sysop mode KC2TIK-L, I am unable to use Echolink.

    Tried the following:

    - Uninstalling /reinstalling
    - Disabling firewalls

    Whenever I hit the "Firewall Test" button, the UDP tests fails.

    Questions:

    1. Is it mandatory for mic/spkr to be connected while configuring and conducting Firewall tests (which I dont think to be)

    2. When the echolink was installed another PC connected to the same router, the tests passed and am able to connect to test server as well as stations. Here the mic and spkr is connected.

    All help and guidance to implement port forwarding / firewall workarounds appreciated.

    73,
    Dilip
    KC2TIK

     
  6. K7MHI

    K7MHI XML Subscriber QRZ Page

    you need to fwd your ports look for something about NAT to a internal static IP
     
  7. KE7VLC

    KE7VLC Ham Member QRZ Page

    I had the same issue then I did some reading up and figured that I needed to change something in the firewall. I ended up doing port triggering rather then port forwarding. Of course I have echolink setup on 3 of my computers in my home.

    Try this site:

    http://portforward.com/help/porttriggering.htm

    Try this and see if this helps. Simple explination is that port forwarding is usually for one computer only but port triggering allows you to have more then one computer on the network using the same ports. Simply it triggers the port to open and pass along the packets for a computer that requests it and then closes the port once the session is closed. So it doesn't matter which computer is trying to trigger the port.

    Now the other possible problem is your network connection between your computer and the firewall is slow or something. Are you using wireless? If so is it wireless B or G? Or is it hardwired?
     
  8. KE7VLC

    KE7VLC Ham Member QRZ Page

    Ok no you don't need to have the mic and speakers setup on the computer to do the test. Thats not what the test is for, it's just testing whether a packet of info can be passed from your computer to the Echolink servers back to your computer.

    I would recommend instead of doing port forwarding try doing port triggering. This will allow you to use several computers to access Echolink. For example, I have 3 computers (well actually 5, plus parts for another 3) that I use for echolink. I use my laptop to connect up from my backyard while sitting out there in nice weather, my living room computer and one in my bedroom/ham shack. I tried using port forwarding but it would only allow one computer to run echolink...all others failed no matter if I had that one computer shut down. So try port triggering. Here is a website you can check out.

    http://portforward.com/help/porttriggering.htm

    Hope this helps. Please let us know the outcome.
     
  9. N9AMI

    N9AMI Ham Member QRZ Page

    interesting

    I quite using Echolink a long time ago cause of this problem. Port forwarding/port triggering does not work. It is how the program is implemented and for some internet connections for some reason it does not work. I fought with the thing for a good 6 months on and off and finally hit the delete button and toss the radio in the junk bin. I was a very early user of the system when it was I-Link I must admit it was tons of fun and I have nothing against it. But it seems if you are on a wireless ISP it doesnt work. And before you folks say my ISP is blocking ports they are not been down that road before. If there was a simple solution other than changing my isp I would try it. FYI I could use EQSO without an issue but I did not care for that system. Good Luck Guys.
     
  10. K0RGR

    K0RGR XML Subscriber QRZ Page

    Assuming that you're using version 2 or higher of EchoLink, it uses ports 5198 and 5199 in both directions with UDP. It uses port 5200 outbound from the PC using TCP. I think what the errors are telling you is the the inbound data on ports 5198 and 5199 are not working, but the PC was able to send data on those ports outbound. This does sound like a port forwarding issue.

    I'm not familiar with the router you mentioned, but it's possible that your DSL or cable modem have built in firewalls that need to be properly configured, as well.
     
Thread Status:
Not open for further replies.

Share This Page