EchoLink UDP hurdle

Discussion in 'Echolink/IRLP Tech Board' started by KE8MXJ, Sep 22, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: MessiPaoloni-1
ad: Left-3
ad: Left-2
  1. KE8MXJ

    KE8MXJ Ham Member QRZ Page

    I'm having the dreaded router/firewall issue that most folks read about.
    upload_2019-9-22_17-4-31.png

    I can't seem to figure out how to get around it. I have windows 10 with a Motorola MG7550 router. I've tried everything I can think of to get this sucker to work. I creates a local static IP for my machine and configured the port forwarding in my router to that machine, below:

    upload_2019-9-22_16-54-42.png

    I confirmed that the Windows 10 firewall wasn't blocking the UDP tests:

    upload_2019-9-22_16-59-31.png

    Firewall Summary:
    upload_2019-9-22_17-0-31.png

    I even disabled the firewall in Windows 10.. still failed the EchoLink connection tests. I turned of the firewall at the router level too and still having issues. I cycled my router several times inbetween change will no luck. Anyone have any ideas what I might be missing?

    Thanks!
    KE8MXJ
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    A proxy server is about the only good fix.

    There is a Echolink proxy java jar that will let you set one up. You need a server available to the outside world to run it on.

    Then you can tunnel the UDP ports to your localhost using a TCP port of your choice.

    Or you can use a public proxy, Most have time limits.

    upload_2019-9-22_16-38-30.png

    Good Luck.
     
    Last edited: Sep 22, 2019
  3. KE8MXJ

    KE8MXJ Ham Member QRZ Page

    That did it! Thanks for your help!
     
  4. KD8DEY

    KD8DEY Ham Member QRZ Page

    Last edited: Sep 23, 2019
  5. KE8MXJ

    KE8MXJ Ham Member QRZ Page

    Thanks for the link. I actually followed those directions to do the forwarding and cycled my router. Not sure what this issue is yet.
     
  6. KD8DEY

    KD8DEY Ham Member QRZ Page

    Try setting Both as the protocol
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    Depending on your ISP, Some do not allow use of the UDP ports that Echolink uses.

    Make sure you have the ports allowed by echolink.exe in your Windows firewall settings.
     

Share This Page

ad: elecraft