Echolink Port Forwarding Long Time issue

Discussion in 'Amateur Radio Software' started by W1MDM, Aug 26, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: abrind-2
ad: Left-2
ad: Subscribe
ad: Left-3
  1. W1MDM

    W1MDM XML Subscriber QRZ Page

    It's been years trying to figure out how to port forward the UDP ports of Echolink. I succeeded the two test and failed on the next one, so overall it is still failed on firewall test.

    UDP 5198 Test #1 ... Succeeded
    UDP 5199 Test #1 ... Succeeded
    UDP 5198 Test #2 ... Receive Failed (10054)
    UDP 5199 Test #2 ... Receive Failed (10060)

    I did this directly from my pfSense router, no other router in my network, even a wifi router.

    I made a firewall NAT and rules on pfSense firewall. Without the new rules everything is FAILED.

    With the Result of 2 success test it still a failure to Echolink Test.

    Anyone fix this issue, especially those who use pfSense as a main firewall router.
     
  2. KD2NOM

    KD2NOM XML Subscriber QRZ Page

    Are you running Windows or Mac? If Windows - try making sure that not only the port forwards are in place but the windows firewall rules are there. Simple test, disable the Windows firewall and then retest - does it work? If yet, the Windows firewall rules need to be modified to properly allow the ports in and out.

    If not - please reply here and we can continue working it.
     
  3. W1MDM

    W1MDM XML Subscriber QRZ Page

    Alright, so NAT was setup, added a new rule to PASS on LAN/udp. It gave me three positive results and last test#2 failed. So now, my last option is your recommendation, since am behind a pfsense firewall so am confident i can disable windows firewall. And it did solved my long time firewall issue. Damn! Thanks for the response.
     
  4. W1MDM

    W1MDM XML Subscriber QRZ Page

    Now am connected direct, succeeded all the firewall test, another issue is that i cannot connect to any conference or directly to a ham callsign. BUT if i use public proxy it right away connect to anybody i want to communicate with.
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    Your problem is still not fixed.

    Most likely your ISP is blocking your UDP ports, And a Proxy server is needed to get around it.

    If you are a jar head, You can setup your own Echolink proxy server using ;

    $ java -jar EchoLinkProxy.jar

    http://www.echolink.org/proxy.htm

    Have Fun.
     
    Last edited: Aug 27, 2017
  6. KG5LRB

    KG5LRB XML Subscriber QRZ Page

    I have same problem. Multiple computers, multiple internet access points. On the latter, I have a ATT mobley and an Apple Air hooked to two different computers. Neither seems to pass the UDP test inbound. AVG firewall engaged with exceptions and not engaged at all. Following.
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    The easiest way to test, Is to disable all firewalls and try it.

    If it still don't work, Then your ISP is most likely blocking UDP ports, And the use of a proxy server will be required.

    Make sure to enable your firewall(s) after test.

    Good Luck.

    upload_2019-8-10_9-0-58.png

     
  8. K2VUD

    K2VUD Ham Member QRZ Page

    I have a very similar issue, except it's with port 5198 except 5199. The last time I tried it (today) I had my system connected it straight to my ethernet link on the ISP, no router The ISP is a uplink provider (Level 3) so there is nothing between my computer and the Internet. I have also disabled the Windows Firewall after removing the Norton one and then rebooted. I get the same result regardless of computer, router, and ISP. The 5198 test always fails the first time. The 5199 test works fine. The second time (or occasionally the third) with no changes at all, the tests work immediately. If you try again in ten minutes or so, same result. Fails on the first try, after that it seems to work fine. It's shame there isn't some sort of "keep alive" protocol for those ports.

    Me thinks it's just buggy.
     
  9. KA9JLM

    KA9JLM Ham Member QRZ Page

    But can you connect to anything ?

    I have seen the test fail, But can still connect using a VPN.

    NAT seems to be the problem with my ISP.
     
  10. K2VUD

    K2VUD Ham Member QRZ Page

    Sort of, if the port 5198 test fails, and everything else succeeds, I get a timeout error when connecting to an Echolink node (I have been testing with 9999). As soon as I refresh the connection and the port 5198 test succeeds, everything works fine.

    I am only using this for my own personal connection on UHF with very low power, so it's not a big deal for me. I am curious how it is working for others, as clearly there are many people using this without issue (I think!).
     

Share This Page