ad: elecraft

Echolink port difficulties?

Discussion in 'Echolink/IRLP Tech Board' started by KC1MUU, Sep 8, 2020.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Subscribe
ad: Left-2
ad: L-MFJ
ad: abrind-2
  1. KC1MUU

    KC1MUU Ham Member QRZ Page

    This seems to have been discussed quite a bit, so I apologize for the repeat. I have been trying to get into Echolink because I believe it is a great tool to have. However, I have been having some difficulties.

    Using Echolink on my iPhone I can only seem to connect to a few sporadic nodes. I have tried just about all the settings with no luck, even on nodes known to be online and active. I also tried on multiple networks and using cellular data.

    On both my windows bootcamp laptop and native Mac I am getting port 5198, 5199 errors. I know that I have to deactivate the firewall, which I did. I also know that I have to allow these ports on the router for the IP address being used, which I have also done. My question, do I have to allow these ports on the modem as well? If so, I couldn't find anyway to do this. Or could this potentially be a larger problem considering the iPhone app won't work as well.

    I have not tried connecting through a local node using DTMF tones but that will be my next attempt.

    Thanks in advance!

    Mike
     
  2. K1RFD

    K1RFD Ham Member QRZ Page

    Mike:

    On your iPhone, please be sure that Relay is selected under Network Connection in the app's settings. If you can connect to the *ECHOTEST* server, all is well at your end.

    As for laptop/desktop, the key there is not so much for the ports to be "open" in the router, but to be sure that port forwarding is set correctly in your router. To set this up, every make and model of router is a bit different, so there's no universal set of instructions, and you will need to consult the manual. Also be sure that any firewall software (such as Windows Firewall) is not blocking incoming ports. The EchoLink installer for Windows should take care of this automatically when you install, but it's worth double checking that an "exception" has been granted to the EchoLink app.

    Another option you have on the Windows app is to use Public Proxy (instead of Direct) as the method of connecting. (In fact, this is the only workable option on some types of Internet services, such as satellite or cellular). You can see this option under Tools->Setup, on the Proxy tab. Again, try connecting to *ECHOTEST* to confirm it's working.
     
    Last edited: Sep 8, 2020
  3. KA9JLM

    KA9JLM Ham Member QRZ Page

    I fight the same problems here.

    My problem is with the type of NAT that my ISP is using.

    My best work around is using a VPN. Cost about $50 a year.

    As Jonathan says, A Proxy server works well also, But many of them limit the time that you can stay connected to them.

    Good Luck.
     
  4. K1RFD

    K1RFD Ham Member QRZ Page

    That seems to be increasingly common with newer Internet services -- essentially they are not assigning you a true Internet address, not even temporarily, and instead you are sharing a NATted one with other customers. Similar to cellular data service.
     
  5. KC1MUU

    KC1MUU Ham Member QRZ Page

    Thank you both for the advice! I was able to connect to the ECHOTEST server on my phone. I tried connecting to the N1IMO repeater system here in NH without luck (I get a timeout error) but I am able to connect to other nodes on my phone. However, I cannot connect to anything including the ECHOTEST node on my windows computer using the same wifi router (I get a timeout error). This is an old router so it may be the issue. I did try another old router and still no success. I am in the process of buying a new one anyway so I will report back after I give that a try.

    Thanks again!
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Your phone may be getting a direct connection and not going thru your router at all, Even if WiFi is on. (Unless your sim card is remove.)

    Some repeaters have to put you (Your Call/Node Number) in their White List before you can connect. Best to ask the Repeater Trustee about that.

    Good Luck.
     

Share This Page