ad: Schulman-1

Echolink not connecting via smartphone/ PC ok

Discussion in 'Echolink/IRLP Tech Board' started by ZS6SP, Oct 16, 2018.

ad: Subscribe
  1. ZS6SP

    ZS6SP Ham Member QRZ Page

    Hi. Could I please get some insight into my problem from the gurus here. I am trying to configure our Clubs Echolink linked to our repeater. It is all set up in sysop mode with router ports open - echolink tests router and firewall ports as succeeded.
    All is working fine if the user connects via a PC but it times out if trying to connect via a smartphone -IOS and Android. Echolink connects fine via smartphone to other repeaters in my area via smartphone but refuses to connect to our clubs echolink. Our internet for Echolink is via a Mikrotik router.
    I suspect it may be a firewall issue but am at a loss as to why it allows a PC to connect and not a smartphone - Oh, and the PC and smartphone is using the same wireless access from a user perspective.
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Some cell phone providers block UDP ports.

    Try a proxy server and see if that works.

    Good Luck.
     
    KB3VWG likes this.
  3. ZS6SP

    ZS6SP Ham Member QRZ Page

    Definitely not that - I've tried all the connection options.Also, I can connect to other club's echolink repeaters via smartphone.
     
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    What is the node number ?

    Maybe we can do a test.
     
  5. ZS6SP

    ZS6SP Ham Member QRZ Page

    Hi thanks - the node is 828739. I am thinking it is more a router firewall issue - problem is it is a Mikrotik router which is not easily configured.
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    I guess you are forwarding UDP and TCP ports ?

    Check these security settings on ZS6MRK-R

    upload_2018-10-18_9-23-27.png
     
  7. ZS6SP

    ZS6SP Ham Member QRZ Page

    Hi, yes the ports are forwarded. My home router allows the ports through to my PC which connects fine to ZS6MRK-R - its just the smartphones that do not want to connect - they receive a time out message (this is via the cellphone network and via my local wifi network) - I managed to connect twice via an android phone yesterday after I connected to another club's echolink (which does not have any problem connecting via iOS and Android). My settings are as shown above. I have restarted Echolink and the remote PC - firewall tests report via Echolink as successful on all ports.
    I have read that there are others also experiencing this issue and have resolved it by putting the Echolink PC on a DMZ in the router. I will see if I can do this on the router.

    I have tried connecting via smartphone direct, relay and public proxy - same issues
     
  8. WG8Z

    WG8Z Ham Member QRZ Page

    Try a different router. Some routers just don't like to trigger the incoming port when coming from a smartphone.

    A network guy told me why, I the just forgot.

    He set his server as a private proxy server for my node which corrected the issue. (Temporary fix)

    When my router/modem took a lightning hit and I had to replace it I bought my own to replace the ISP leased unit.

    It now functions as it should.

    And saves me $15 a month.
     
  9. ZS6SP

    ZS6SP Ham Member QRZ Page

    Thanks - for the replies - will try the option.
     

Share This Page

ad: ProAudio-1