EchoLink No Audio But Only If I Connect To Other Nodes

Discussion in 'Echolink/IRLP Tech Board' started by W3UWU, Jul 22, 2021.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: L-MFJ
ad: HRDLLC-2
ad: abrind-2
ad: Left-2
ad: MessiPaoloni-1
ad: L-Geochron
  1. W3UWU

    W3UWU Ham Member QRZ Page

    OK so set myself up an EchoLink simplex bridge, did some testing and it was working sort of -- some minor issues, forwarded ports 5198-5200 (TCP/UDP), opened firewalls in the Windows machine, all tests pass now.

    However I cannot get audio in either direction, not on the EchoLink test or any other node I connect to.

    HOWEVER, if I hop on another node, dial my node, it connects... and audio works fine! Both ways. Flawlessly.

    I've been messing with this for the past couple of hours, I'm really stumped on what may be causing that, or how to remedy it. I made sure I have no other EchoLink nodes on my network, made sure I'm not behind a CGNAT...

    While I'm connected to EchoTest, I can see that my control packets are making it, but my data packets are not (which is what I sort of expect). I'm suspecting my firewall may be filtering _outbound_ but that's a bit odd.

    Any ideas on where to even begin?


    Edit: for now I'm just going to make the node I wanted to connect to connect to me, but I want to be able to move my bridge around via DTMF codes so I'll have to fix this at some point...

    I'm behind a UniFi security gateway managed by a Unifi controller, so far got rules to allow all outbound traffic plus allow inbound on 5198-5200.
     
    Last edited: Jul 22, 2021
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    I have seen this happen when UDP communication fails.

    When that happens, Normally it never really totally connects (TCP Only) and times out in about 1 minute on UDP fail.

    NAT or your Firewall settings are normally the cause.
     
  3. K1RFD

    K1RFD Ham Member QRZ Page

    This problem is not familiar, but it sounds like an issue with UDP 5198 somewhere along those layers. Did you try rebooting the router?
    Does the Inbound test succeed?
    Incidentally, no need to forward 5200, nor any TCP ports. Just UDP 5198-5199.
     
    KA9JLM likes this.
  4. W3UWU

    W3UWU Ham Member QRZ Page

    Ack, yeah should have been explicit on that, yeah both the outbound and inbound tests succeed. I forwarded all 3 ports to remove all doubt, but I'll be adjusting my rules to remove 5200.

    However, I did not try rebooting the router, I'll go ahead and try that later tonight and see if that remedies the issue.

    The router does have some SIP rewrite functionality, I tried messing with that just in case that was an issue, but it didn't seem to be.

    When I ran EchoLink from my desktop (same network) prior to this setup I had no issues, and I've moved my desktop to a proxy setup to prevent conflicts on the IP address/routing/etc. so again -- this one is weird to me.

    Yeah, I had that prior to setting up my firewall settings correctly, the weird thing is it works fine if you initiate a connection from another echolink node via DTMF tones. That is the detail that is really leaving me confused.

    Which also may suggest why the inbound test succeeds, new connections coming in work fine, it's when my EchoLink is the initiator that it doesn't.
     
  5. W3UWU

    W3UWU Ham Member QRZ Page

    Props to K1RFD -- a reboot of the router fixed it. Kind of weirded out on that since the USG should apply settings when I configure them in the controller, but maybe it was holding onto something until I issued a reboot/reprovision to remove all doubt.

    Thanks everybody for racking their brains on this one.
     
    KA9JLM likes this.

Share This Page