Echolink firewall problem I use my computer host to wirelessly connect to the router

Discussion in 'Echolink/IRLP Tech Board' started by BH3MDE, Aug 7, 2019.

Tags:
?

firewall set problem

  1. firewall set

    0 vote(s)
    0.0%
  2. computer host to wirelessly connect to the router

    0 vote(s)
    0.0%
  3. IP address cannot be fixed every time

    1 vote(s)
    100.0%
ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: Left-2
ad: L-MFJ
ad: MessiPaoloni-1
ad: Left-3
  1. BH3MDE

    BH3MDE Ham Member QRZ Page

    Echolink firewall problem is always troubled. I have set the port of the open router.When I use my computer host to wirelessly connect to the router. IP address cannot be fixed every time.I don't use the network cable to connect directly, and I can't pass the verification. If the proxy server is unstable every time, it may be disconnected the next time you can't connect. Who can solve this problem?
    [​IMG]
     
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Turn off DHCP
     
  3. WA4WEQ

    WA4WEQ Ham Member QRZ Page

    "Turn Off DHCP" is not complete enough an answer - end user may not know whether you're talking about the PC's NIC or the router.
    Let me try.
    Echolink requires a port forward from your router to your PC. You CAN have a fixed IP address even via Wifi. There are two ways to do it.
    Background: In most home networks your router hands out addresses to network devices, wired and via wifi. The service that does this is called DHCP. Most home networks are set up on 192.168.X.X, and out of the box most routers will be on the 192.168.0.X or 192.168.1.x network. The default network is set up as a Class C network - that's not really important but here is what is: A Class C network has 255 addresses available. The DHCP (Dynamic Host Configuration Protocol) service hands out addresses to network devices. It is usually set up with a specific scope. Most home networks are set up with a DHCP scope or address pool from 192.168.X.100-200. This leaves 2-99 and 201-254 available.
    Now to the two methods.
    Method 1: DHCP Reservation
    Depending on your type of router, you might be able to configure the router to reserve the address your computer has. This is called a DHCP reservation. The DHCP should have a list of current address "leases". Log onto the router's admin page, find the DHCP configuration screen, and there should be a list of hosts who have received DHCP addresses. Most DHCP servers will allow you to add a reservation for a given host. Hosts have a physical address (MAC address. You can add a DHCP address reservation so your Echolink PC always has the same internal network address. Set up your Echolink port forward to the permanent address and this should solve the problem.
    Method 2: Use a static address on the PC itself.
    Log onto your router's admin page. Look at the DHCP service again. See the scope addresses (also called the address pool) in use. If you use ATT internet and the router they provided, they probably have the scope set to 192.168.1.1-253, using every available address except the router itself which ATT configures as 192.168.1.254. Other routers usually are set out of the box as 192.168.X.1 where X is 0 or 1. Most of them have the DHCP scope set to 100-199. This leaves the address space from 2-99 and from 201-254 available for static addresses. If you have an ATT router, you can change the scope to 100-199, which is plenty of addresses for most home networks.
    If your space NOT in the DHCP scope is 2-99 and 201-254,
    • Hit Windows+R key to bring up the Run dialog.
    • type cmd in the text box and hit Enter. This will bring up a command line box and prompt.
    • type ipconfig and hit Enter.
    • About the third line down you'll see ipv4 address. Note your IP address. It should be 192.168.X.X Note the third number which is probably 0 or 1 e.g. 192.168.1.137
    • Select any address outside the DHCP scope. Here we'll use 10 as your example
    • Now, on your computer, right-click the network icon in your taskbar.
    • Click Open Network and Internet Settings
    • Click Wifi on the Left.
    • Click Change Adapter Options.
    • Double-click your Wifi adapter
    • Click Properties in the Status window.
    • Double-click Internet Protocol Version 4 (TCP/IPv4)
    • Click the radio button "Use the following IP address"
    • Type in 192.168.1.10 as IP address (be sure you use the same third number as the IP address in the command box)
    • Subnet mask should be 255.255.255.0
    • Default gateway should be 192.168.1.1 (look at the address in the command box - it will show the gateway address you need.)
    • For DNS you can put in your gateway address, same as the previous line. If you know what DNS is you can also use any public DNS server like 8.8.8.8 (Google DNS) 1.1.1.1 or 9.9.9.9 - these all work fine)
    • Click OK until you get back to the status window. Click Close. Your PC now has a static address.
    Go back to your router admin page and make sure your Echolink port forward is going to the new address of 192.168.1.10. The port number can remain the same.
    I know this seems arcane and complicated, but it's really just several little fiddly bits and very straightforward. Either of these methods - the DHCP reservation or the static address assigned at your Network Interface Card - will work, but your router must allow DHCP reservations (some of ATT's routers don't for reasons unknown; probably a cost-cutting measure) or must allow you to modify the DHCP scope so you have some free space for static addresses assigned at the endpoint PC.

    Note: Setting a DHCP address or a static address also comes in very handy for a network printer. They tend to switch addresses after power outages on networks where the router hands out all the addresses.
    I hope this helps.
    73 de WA4WEQ
     
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    Nice job.

    I did the short version, Did not know if the OP needed a computer class.

    73
     
    WA4WEQ likes this.
  5. KD8DEY

    KD8DEY Ham Member QRZ Page

    reserve the IP address using Mac address of the computers network connector in the router

    set computer in IPV4 settings to always use that reserved IP address..

    make sure 5198 5199 & 5200 are open on router and in windows firewall along with the echolink executable.....
    (Short version)
    Ymmv
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Long Version.

    Make sure TCP and UDP ports 5198 5199 & 5200 are open on router and in windows firewall along with the echolink executable..... :D
     
    K6CLS and KD8DEY like this.
  7. WA4WEQ

    WA4WEQ Ham Member QRZ Page

    I wish I knew what kind of router OP was using - could give specific instructions on how to do a port forward. On a DDWRT router and many consumer routers it's easy. On my preferred router, the Untangle Firewall, it's also easy. But I have no idea what OP is running in China. One other issue - I know the Great Firewall does DPI and lots of traffic is blocked. Echolink only lists five nodes in China - three of the callsigns are in QRZ, in Shenyang, Dalian, and Shanghai. The other two have IP addresses in Qingdao and Shenzen. Not sure whether it's easy to get ports open there or not.
     
  8. KL7AJ

    KL7AJ Ham Member QRZ Page

    I've never had any problems getting echolink to work flawlessly and we have the flakiest internet on the planet. (Not just opinion...actuall government statistics!)
     
  9. KJ4VTH

    KJ4VTH Ham Member QRZ Page

    Any port in a storm ...
     
  10. KD8DEY

    KD8DEY Ham Member QRZ Page

    Spectrum??!!
     

Share This Page