Digipan and Windows 10

Discussion in 'Working Different Modes' started by N2VWP, Aug 3, 2015.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: MessiPaoloni-1
ad: HRDLLC-2
ad: L-MFJ
ad: L-Geochron
ad: Left-2
  1. N2VWP

    N2VWP Platinum Subscriber Platinum Subscriber QRZ Page

    Good afternoon all!

    I recently upgraded from Windows 8.1 to Windows 10.

    Long story short, my PTT is set on COM2, CAT control on COM3.

    All other software (JT65, HRD, etc) work fine, but Digipan just refuses to access the serial port. Do I need to go into Device Manager and set the port to settings other than 9600/n/8/1?

    I realize I can just use DM780 instead, but honestly, I find it a bit confusing compared to Digipan's simplified system.

    Thanks for any info!

    --rob
    n2vwp
     
  2. W9GB

    W9GB Ham Member QRZ Page

    Go to Device Manager and double-check for proper driver loading (No Exclaimation points in Yellow triangles).

    Next, check to see the Port Number (COMx) assigned for those hardware ports.
    Windows 10 migration may have changed. You can change those assigned COM numbers.
     
  3. N2VWP

    N2VWP Platinum Subscriber Platinum Subscriber QRZ Page

    Yeah, originally it had my PTT com port set as COM5. Once again, all my other software worked, Digipan didn't... So, knowing that Digipan is pretty old compared to everything else, I actually changed the com port down to 2, re-tested all the other apps just to make sure it was functioning properly on COM2, and digipan still can't open it.

    Definitely weird! Thanks for the reply!

    **EDIT**
    No errors in device manager.

    I do wish I took a look at the device manager in 8.1 previous to wiping it out with the 10 install... I was curious if I had to 'hardcode' the port to 4800bps or something similar (my FT-950 uses 4800bps with HRD)

    --rob
     
  4. N2VWP

    N2VWP Platinum Subscriber Platinum Subscriber QRZ Page

    Hmm, can't edit my post any more, but one thing I did forget to mention... I am using a Yaesu SCU-17 usb interface.

    I was reviewing some old notes I found, as well as some websites, that showed that Digipan and the SCU didn't play well together. It's quite possible I didn't ever get digipan working on this station. (I have another station that has an Icom 718 with a Rigblaster interface that does work fine)

    The plot thickens... heh.

    --rob
     
  5. W9GB

    W9GB Ham Member QRZ Page

    The Yaesu SCU-17 contains THREE Important Integrated Circuits for its operation.

    Microchip USB2512B : Dual Port USB 2.0 Hub
    Texas Instruments PCM2903B : USB 1.1 Audio CODEC
    Silicon Labs CP-2105 : USB to Dual UART Bridge

    image.jpg
    The SCU-17 is equipped with two virtual COM ports (SiLabs CP-2105),
    which can be used for CAT communication and TX control operations.
    Installing the virtual COM port driver software on a computer makes possible CAT communication
    via a USB cable to the SCU-17. This will allow computer control of TX (PTT, FSK).

    Silicon Labs, Inc. (Austin, TX) : CP-2105 USB to Dual UART ports.
    http://www.silabs.com/products/interface/usbtouart/Pages/usb-to-uart-bridge.aspx?tab=info

    The PTT Audio LED is deceiving.
    It does not light, when audio is routed via USB / serial ports (6, 7),
    but does operate via audio jacks (10).

    image.jpg

    Ethan Poole, KW4EK suggested this "work around" for FLDigi usage with SCU-17, here on QRZ.
     
    Last edited: Aug 3, 2015
  6. K9PHT

    K9PHT Ham Member QRZ Page

    I just got my WIN10 going and already heard from someone that the FLDIGI mode doesn't run right on WIN10. Haven't tested mine yet..

    I sort of remember I had to play with my SOUND CARD on my M90 XP-PRO unit to get it to work right there. Hope I don't have any problems using WIN10 on this LAPTOP...

    Roy Ken
    K9PHT-King George VA...
     
  7. K4JDH

    K4JDH Ham Member QRZ Page

    If Digipan fails to come back try Airlink Express. It is very similar to Digipan in all respects and offers more modes.
     
  8. N2VWP

    N2VWP Platinum Subscriber Platinum Subscriber QRZ Page

    Thanks much for the replies...

    As far as hardware settings for the SCU, everything was working fine in 8.1 as well as every other program with Windows 10, W9GB... it seems to be limited (thankfully) to Digipan itself.

    I'll take a peek at Airlink Express, too... thanks K4JDH!

    Can't comment on FLDIGI Roy, but I saw the same posts... I'll keep my fingers crossed for you! :)

    --rob
     
  9. KA9JLM

    KA9JLM Ham Member QRZ Page

    Have you tried to run it in a windows compatibility mode ?

    It sounds like your hardware is playing. Did you look at hidden devices ?

    Port assignment and settings can be reassigned manually if needed. A Hub can hose you.

    Good Luck.
     
  10. N2VWP

    N2VWP Platinum Subscriber Platinum Subscriber QRZ Page

    I'll have to try compatibility mode... but Airlink Express worked like a champ right off the bat, no special workarounds necessary... so thanks for that suggestion.
     

Share This Page

ad: AbAuRe-1