dentron rf amp

Discussion in 'Amateur Radio Amplifiers' started by M0PMD, May 20, 2020.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: Left-2
ad: Subscribe
ad: L-MFJ
  1. M0PMD

    M0PMD Ham Member QRZ Page

    hi all i have a dentron gla 100 that i can not get to excite even with
    rf applied at 100 watts the relay is new so any help would be appreciated
    or a repairer in the uk
     
  2. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    Is it "keying" correctly (does the red lamp illuminate and you hear the relay click)?
     
  3. K7TRF

    K7TRF Premium Subscriber QRZ Page

    As posted above, is the amp keying into its active state as shown by the front panel LED?

    If not, have you tried simply grounding the relay keying line to the chassis and have you checked that the standby switch is working by seeing if the +12V is present at the top of the relay coil (point B as shown on the schematic)?

    Are you sure your amp keying line is good and properly connected to the transceiver?
     
  4. M0PMD

    M0PMD Ham Member QRZ Page

    the relay is latching when grounded to the chasis so i have used a switch
    to operate so the only connection to the radio is the rf in the original fault was
    tracing in side 1 of the tubes
     
  5. K7TRF

    K7TRF Premium Subscriber QRZ Page

    That's good, so the amp is actually keying into operational mode via your external switch.

    I'm not sure what you're trying to say here.
     
  6. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    "Using a switch" can be dangerous and damage the amplifier -- for example, if you start to transmit, then use the switch to key the amplifier; or if you release the switch to unkey the amplifier while you're actually still transmitting.

    Safer to let the transceiver "key" the amplifier. Or at least use a dual switch footswitch that always activates the amp first, then the transmitter, and releases in the reverse order.

    HEIL makes one that does exactly that: https://heilsound.com/products/fs-2-footswitch/

    Or of course something like that could be homebrewed, if you're handy with tools.
     
  7. M0PMD

    M0PMD Ham Member QRZ Page

    I am using a external foot switch so the switch only grounds
    the relay to the amp chassie and the only connection to the radio
    is the antenna for the rf i am putting 100 watts in and about 25 watts
    out the tubes are lit but are not getting ecxieted
     
  8. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    Lots of possibilities there.

    One is: The GLA1000 did not have tuned input circuitry, so if you're using a solid state transceiver with it, the transceiver may not like the load the amp presents and is folding back in power to protect itself.

    Another is: Bad T-R relay contacts, which might be cleaned or might be replaced.

    Another is: Of course, bad tubes or even one bad tube.

    That's an old amp that was designed to mate with tube-type transmitters. Their market value here in the States is basically "about nothing." But if it worked recently and doesn't work now, it could be fixable.
     

Share This Page