CDE/HAM IV Rotor Control

Discussion in 'Antennas, Feedlines, Towers & Rotors' started by VE2CY, Aug 31, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-2
ad: K5AB-Elect-1
ad: Subscribe
ad: MessiPaoloni-1
  1. VE2CY

    VE2CY Ham Member QRZ Page

    Hello Glen - I did a double take logging back in - "K9SJH" was the "Featured" member, lol - close !

    Okay, thanks for letting me pick your brain this way, I greatly appreciate the assistance. I did your last suggestion and found this: between pins 1 and 3, I had the correct resistance, and when rotating the unit, the ohmeter moved slowly. However, although I would also get the correct resistance between pins 3 and 7, the needle would not move during rotation - it just stayed the same.

    So, can I conclude the wiring is good (I do have a connector in the long line). Maybe, as you initially suggested, something is wrong with the rotator pot itself ?
     
  2. K9STH

    K9STH Platinum Subscriber Volunteer Moderator Platinum Subscriber QRZ Page

    The reading should stay the same between Pin-3 and Pin-7 because that is across the entire potentiometer. Does it move slowly from Pin-1 to Pin-7 as you rotate the unit or does it jump around? If it moves slowly across Pin-1 and Pin-3 and then again slowly across Pin-1 and Pin-7, then the potentiometer is probably OK. You are then measuring including the wiper and it is the wiper that almost always presents the problems.

    Glen, K9STH
     
  3. VE2CY

    VE2CY Ham Member QRZ Page

    Ok great, we got it - I mistook your previous statement of which wire to check, but have just done it as in your last posting - both 1-3 and 1-7 move slowly, and 3-7 is the total resistance, so the potentiometer is good, and my connector. That just leave the controller, and there is not much in there apart from the switch hardware.
    However, I have now reconnected the wires (they were twisted and tinned), put them back on, and now the meter is "more or less" tracking ... I say more or less because the antenna is absolutely still, but the needle is "wobbling" plus or minus one marking on the meter. I set it for 90 deg and in 10 secs it reads 95 ! then 10 secs later it is saying 100 deg. Hmm, it has settled down but still moves a bit. I wonder what component that could be, there isn't that many. I guess I could just replace the most likely candidates?

    Joe VE2CY
     
  4. WA7ARK

    WA7ARK Ham Member QRZ Page

    Check the DC output voltage made by the little transformer, diode CR2, filter cap C1, Zener diode CR1 by reading with a voltmeter connected between pins 3 and 7. The DC voltage there should be rock solid..., even while the rotor is turning...

    With the pot connected, at any rotor position, (the voltage from pin 3 to pin 1) plus (the voltage from pin 1 to pin 7) should add up to (the voltage from pin 3 to pin 7).
     
  5. VE2CY

    VE2CY Ham Member QRZ Page

    Just tried it - seems as steady as a rock, unlike the control meter which is still squirming like a kid in a dentist chair, hi hi ... on my Micronta, it reads 13 volts, and I can't tell if it has a slight wiggle or not, but certainly no 10 deg shift like the meter. (it's down to 80 now from 100). Could the meter be inducing it's own wiggle? I must add, the main flutter or wiggle seems to have gone, and there remains just this slow drifting ...

    ps - it's a Ham III
     
  6. WA7ARK

    WA7ARK Ham Member QRZ Page

    You are down to two possible bad components; the meter (expensive), or the Cal Pot (any 5k pot with a built-in on/off switch will work).

    My vote is on the cal pot...

    Try isolating the pot, hook an Ohmmeter across it to see if it jumps around...
     
  7. VE2CY

    VE2CY Ham Member QRZ Page

    I'm voting with my pocketbook, lol ! I hope you are right!

    I have left it on for an hour now, and it totally drifted off reality - oddly, if I click the Pot on to calibrate, the needle responds with the calibrate movements, but rotating the antenna (always 100%) and the meter needle currently doesn't move ! (not much jumping or wiggling around right now) ... so that's odd, it almost points back to the 500 ohm pot in the rotor? Weirder and weider !!!
     
  8. VE2CY

    VE2CY Ham Member QRZ Page

    Hmm, another observation - having shut down the controller overnight, this morning the needle followed the rotation commands, but was back to fluctuating 10 degrees or so. Is there something that slowly heats up over an hour, and then causes the problem? I would not think the Cal Pot, and the meter always responds in calibrate mode to adjustments - could the older transformer or capacitors be the culprit?
     
  9. VE2CY

    VE2CY Ham Member QRZ Page

    Yet another clue - when I click the calibrate pot, the needle now jumps 20-30 degrees. And I can move the needle with the knob whether in Calibrate position, or Calibrate Off position - this is not supposed to happen, correct? WA7ARK, you may be correct !
     
  10. NG1H

    NG1H Ham Member QRZ Page

    An FYI - from your posts it sounds like it is not the potentiometer. But in case you (or someone else reading this post) winds up replacing it there is something to check on a new unit. I purchased a new unit about a month ago. Installing it (and a new ring gear, ball bearings and grease) everything worked fine at first but after a few tests noticed the needle jumping around and eventually smelled smoke. Tearing it back apart we discovered that the wiper on the new unit can short out the part. The assembly is in a helix which allows the wiper to move a bit past the 180 degree point from both directions. One direction it is on top of the overlap and can't short. The other direction it slides under/between the helix. This space was too small and so the wiper arm shorted out the two ends, melting part of the potentiometer. Luckily nothing else was damaged. I sent MFJ pictures of the problem and they immediately sent out a replacement. The replacement functioned perfectly.

    20190803_121829.jpg 20190803_121032.jpg 20190803_121032.jpg 20190803_121829.jpg 20190803_121032.jpg
     

Share This Page