Can't Get WSJT-X to Transmit

Discussion in 'Mac Ham Radio on macOS & iOS' started by K8GRR, Oct 12, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-Geochron
ad: Left-2
ad: abrind-2
ad: Left-3
ad: L-MFJ
  1. K8GRR

    K8GRR Premium Subscriber QRZ Page


    I'm trying to configure my station for JT65. I think I'm almost there, but the problem I'm running into is that when I answer a CQ or click "Tune" in WSJT-X, it puts my Kenwood TS570D into TX - but there is no output. The PTT test button in the software indicates that I have a good connection, and as I said the radio is triggered, but nothing comes out. I have tried increasing the TX output level on the Signalink, but this makes no difference.

    I'm using the current version of WSJT-X, version 10.12.6 of the Mac Sierra OS, and I have a Signalink USB for my interface.

    I suspect the problem is that my iMac sound card is not sending anything to Signalink USB (and then to the radio). I've set my Mac audio input and output settings for "USB Audio Codec" (which works for PSK31) and the audio format to "2ch 16 bit integer 48.0 kHz. Through trial and error it appears that 38400 is the appropriate baud rate (both WSJT-X and the radio are set for this). I have tried cranking up the TX level on Signalink, but this hasn't made any difference.

    When operating PSK31 with FLDIGI and FLRIG, I've occasionally run into situations where the sound output randomly goes through the computer speakers, but this has been the exception rather than the rule. In the present case the radio indicates that it is transmitting - but there is no output anywhere.

    Any help that you can provide would be appreciated.


    Brian, K8GRR
  2. K7GQ

    K7GQ Subscriber QRZ Page

    Throwing a few questions out:

    -- have you set the menu item 34 for the audio output level?
    -- what method is WSJT-X using to put the rig into transmit?
    -- are you using the interface port on the rear of the rig?
    -- did you use Audio Midi Setup to obtain 2ch 16-bit 48kc for both Input & Output?

    I have occasionally had an interaction with MacOS System Preferences/Sound that make are illogical, but when selecting the device I want to use for digital work, the problems go away
    Last edited: Oct 13, 2017
  3. AI6AK

    AI6AK Premium Subscriber QRZ Page

  4. K8GRR

    K8GRR Premium Subscriber QRZ Page

    Thank you for the suggestions, questions and observations.

    Menu 34 is set to "9" (max)
    Using CAT to put rig in transmit (and it tests successfully)
    Yes, using interface port in rear (and this works for PSK31)
    Yes both audio input and output are set for 2ch 16 bit 48kHz
    Memory settings have been changed
    Hesitant to download driver in view of the fact that rig works for PSK31 using FLDIGI

    Any additional thoughts and/or suggestions would be much appreciated.

  5. K8GRR

    K8GRR Premium Subscriber QRZ Page

    After I installed what I believe to be the latest SiLabs driver and installing the JP3 jumper in the SignaLink, I thought I had my WSJT-X problems licked. Everything worked flawlessly for about 3 straight days - then it didn't. Now, most of the time when I click "Tune" in WSJT-X, the audio output goes through the Mac speakers rather than into the SignaLink. Curiously, at the moment I am not having this problem with FLDIGI/FLRIG.

    My guess is that this is a manifestation of the sound card issue inherent in current iterations of OS X (I am using v. 10.13). All appropriate Midi and Sound settings are used for each mode.

    This is of course, very frustrating given that there were no problems whatsoever immediately after I made the changes described above, but then there were. The fact that FLDIGI/FLRIG works fine (for now) is also a puzzlement.

    Any observations would be appreciated.

    Brian, K8GRR
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Could two pieces of software be fighting over one piece of hardware ?
  7. W7HFF

    W7HFF Ham Member QRZ Page

    Brian, in your Mac you have a soundcard already, plus signalink.

    Check FLDigi configuration, which audio devices are used with them?

    You'll want to run Midi in Applications/Utilities folder and set input/outpot devices the same (i.e. SignalLink's audio devices).

    That should take care of the problem.
  8. WV8A

    WV8A Ham Member QRZ Page

    The "audio going to the speakers instead of to the radio via USB" problem is a well-known and common issue with many combinations of older Mac hardware and both older and current OS versions. There was some extended discussion of this in a thread on this forum and others about a year ago, with a few solutions proposed.
    I had this problem with my 2011 MacBook Pro 15", under three different OS installs. The only effective solution was to essentially create a USB bus separate from the internal USB hardware, using a Thunderbolt-to-USB adaptor. Currently using 2016 MBPro with USB-C and having no problems. WSJT-X, SignaLink, FT-897D.
    VK3BL likes this.

Share This Page