ad: elecraft

Beware Samsung SSD drives...!

Discussion in 'Computers, Hardware, and Operating Systems' started by G4COE, Aug 20, 2019.

ad: L-HROutlet
ad: l-rl
ad: abrind-2
ad: Left-3
ad: Left-2
ad: L-MFJ
ad: Subscribe
  1. KA9JLM

    KA9JLM Ham Member QRZ Page

    Not sure why you need a driver for a SSD drive. If the drive don't work, How does a Windows driver load ?

    It is like a network adapter that does not work. Errors like "Download the latest driver" or "Please report this error to MS to find a online solution", And a keyboard error that says "Keyboard not found, Press any key to continue" Crack me up.

    Your setting must be in the BIOS. Is your drive 0 or 1 ?

    Good Luck.
    Last edited: Sep 21, 2019
  2. WF7A

    WF7A Subscriber QRZ Page

    Just as an FYI, Dave: Crucial's SSDs are manufactured by Micron Technology.
  3. G4COE

    G4COE Ham Member QRZ Page

    Ah made by Micron... that's good to know, main drive on naught and storage drive on 1. Crucial works fine but the Samsung Evo 860 seems lock up after a day or less, reboot and all is well.

    As I mentioned, the only thing I've not tried is to run the drive in IDE mode and not SATA, this is what others have done. Just curious if the Crucial did the same trick.... but nope! Sounds like your SSD driver explanation is the reason it makes no difference which driver I run in device Manager.

    Not only do I keep an external clone, I still have the original 80Gb 'spinner' I can hook back to parked in an internal bay, I've still got bags of space on that left.... I'll probably never fill a Alligator drive with all them terabytes.

    I'm being convinced SSD is the way to go, since my last post some while ago I switched to Crucial just to try. Unknown to me Trim was enabled according to CMD prompt even on the old WD spinner drive, I thought it was only SSD's.

  4. KR3DX

    KR3DX Ham Member QRZ Page

    As I understand it, only writing causes wear to the memory cells of an SSD. Reading is done without causing any wear.
  5. G4COE

    G4COE Ham Member QRZ Page

    Yeah yeah of course, how silly of me, thanks for pointing that out.

    May I add, I tried a Samsung Evo860... that wouldn't play ball any way or form on my Gigabyte AMD mobo with a 3.6GHz AMD cpu.... it'd work a day or a few hours then lock up, reading on web it's a major issue with many AMD cpu's and SSD driver/firmware, no way could I cure that. Some said use MS drivers for the SSD, some say use IDE settings in bios - neither worked for me.

    Samsung technical didn't want to play ball so sod em', they are aware of this problem but NO FLIPPING WARNINGS on the box or THEIR web sites. I'll never buy Samsung products again.

    The Crucial BX200 240Gb works flawless so I'm thinking of 'upping it' to a Crucial MX series 500Gb drive. I posted elsewhere about this Samsung problem.


Share This Page

ad: vanity