ad: ProAudio-1

Basic iMac connectivity with TS-590SG

Discussion in 'OS: Mac OS' started by W0MPM, Jul 17, 2018.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Subscribe
ad: Left-2
ad: MessiPaoloni-1
ad: L-MFJ
  1. W0MPM

    W0MPM XML Subscriber QRZ Page

    OK. This is the setup for RUMlogNG with the TS-590SG using the 590SG menu 68 (USB) with the suggested defaults. Thanks for all the help here and on the other thread.

    Screen Shot 2018-07-19 at 17.40.36.png
     
  2. W0MPM

    W0MPM XML Subscriber QRZ Page

    I tried to put together instructions. If not correct or in need of revision input is solicited. I put myself in the place of someone who has unboxed a TS-590SG and FedEx just dropped the iMac on the porch a few hours earlier. I don't know and don't care about computer hardware and software; just want to hook my radio up to it and go.

    PS: Amateur Radio websites also should use Monaco. For Apples.
     

    Attached Files:

    DL2RUM and K3DCW like this.
  3. DL2RUM

    DL2RUM Ham Member QRZ Page

    I would ask you to verify the flow control settings. The Power up line options must be unchecked, this is correct. Since it is a USB connection, you shouldn't need any flow control. Or does the Kenwood still have an additional RS-232 port? Can the flow control lines used for CW, PTT or FSK keying?
     
  4. W0MPM

    W0MPM XML Subscriber QRZ Page

    The only reliable setting to get bi-directional response between the program (RUMlogNG) and the radio (TS-590SG) seems to be with BOTH flow control setting selected.

    Trying various combinations: both selected, both unselected, one or the other selected. It at first appeared both selected was correct. Then it seemed both unselected or both selected but not either one alone. Then trying combinations it appeared the sequence leading up to settings might be at work (my assumption is the lines are left in a 'last state' or something? I don't know anything about their behavior). I tried powering the radio off and restarting the program because I seemed to get stuck with data from RUMlogNG to the TS-590SG but not from the TS-590SG to RUMlogNG. All I can say is that going back to both selected has yielded correct operation.

    Since writing the previous paragraph I've tried some more. Started including the RUMlogNG menu 'Transceiver, Reset CAT I' command into the sequence. In some instances that made the radio respond to RUMlog inputs. But with different settings. Very frustrating. All I can say is that for now I am going with both flow control setting selected as with a clean startup at the radio and RUMlog it seems to always work. Nothing else, so far, always works.

    The TS-590SG (and I believe the TS-590) does have a DB-9 connector option com port - RS-232C. I am using only the USB.

    I have not tried any digital data modes (ever not just with this radio). Will soon. But not until I am satisfied that the basic operation is correct and that I understand it.

    Kenwood documentation is here:
    http://www.kenwood.com/i/products/info/amateur/software_download.html
    Not intuitive to locate; naturally. I tried looking for some hint in the PC Control Command Reference. But it is gobbedlygook to me.

    There may be some (obscure?) setting here that is odd. Maybe I'll post on the groups.io 590 and ask for others setting.
     
  5. W0MPM

    W0MPM XML Subscriber QRZ Page

    Been out for the afternoon (helping a new ham get a shack together). Radio was off and iMac shutdown. Turned radio on. Started iMac. RUNlogNG and TS-590SG talking nicely to each other with both flow control selected in preferences.

    At this juncture unless something stops working I'm going to just go forward. It may not be correct; but it's functional. Sometimes PFM just happens. As my old Dad used to say.
     
  6. W0MPM

    W0MPM XML Subscriber QRZ Page

    With the both flow control not selected (as you suggest) the radio follows RUMlogNG. If I select a spot from DX Spots or enter a frequency into the call sign the radio tunes. But the opposite does not work: tuning the radio the reading in RUMlogNG does not follow the radio VFO reading. Reset CAT #1 has no effect.

    Changing to select only flow control RTS/CTS and then Reset CAT #1; then everything seems to work both directions.

    Since this is more minimal (fewer options selected) I'll try this for awhile.
     

Share This Page