Assistance request. TS140S interfacing with Ham Radio Deluxe

Discussion in 'Amateur Radio Software' started by K4VMG, Jul 12, 2019.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: L-MFJ
ad: Subscribe
ad: Left-3
ad: MessiPaoloni-1
  1. K4VMG

    K4VMG Ham Member QRZ Page

    I am struglging to get the TS140S to communicate with HRD.

    I have the PIEXX interface baord installed and a serial to USB interface cable and updated drivers.

    HRD scans the ports and recognises the port but keeps retuning Frequency = o then I get the red X error.

    Has anyone successfully interface with Windows 7 and a Serial to USB connector.
     
    Last edited: Jul 12, 2019
  2. KA9JLM

    KA9JLM Ham Member QRZ Page

    Some of the older radios do not have VFO data available.

    The TS140S may be one of them.

    Good Luck.
     
  3. K7MEM

    K7MEM Ham Member QRZ Page

    That is the normal response fro HRD, when it can't read data from the interface. By itself, HRD doesn't really provide enough information. You need to look at the device.

    What does the Device Manager tell you?

    If you are monitoring the Serial Ports with the Device Manager, and then plug in your USB to Serial Port converter cable, you should see a serial port generated. If the port is generated, but has a small yellow triangle, it has a failure and you need to find a different driver or a different USB to Serial Port converter.

    USB to Serial Port converters work differently on different OSs. I have 5 or 6 of them. Some work on XP, others on W10. A few work on both.

    The PIEXX interface has a default of 4800 baud. Is HRD set for that speed?

    After I posted, I found the following link. It is the same setup that you are using.

    https://www.qsl.net/vy2ac/digital.html
     
  4. K4VMG

    K4VMG Ham Member QRZ Page

    Thank you for the responses, I;ve spent many hours now trying to get this working and I have come to the conclusion that the baord is faulty.
    I'm using the FTDI chipset for Seerial to USB cable and Windows shows this as being fully operation and sets the com port as 2 (I can and have tried changing it.)
    So far I have tried all combinations of Baud rate stop bits and parity wthout success PIEXX say their boardrd is set up for 4800 but I've even in desparation tried to change that !
    Yes the Vy2AC set up is the same, I even tried to look him up but no contact details so I couldnlt email him !
    Thank you for taking the time to repsond, I'll try to contact PIEXX but their website messaging service crashes and they donlt answer phones !
     
  5. K7MEM

    K7MEM Ham Member QRZ Page

    VY2AC does have a email address on his web site. It's at the bottom of the page.

    This may sound dumb, but have you tried a Null Modem cable or adapter?

    Years ago, I wanted a CI-V interface for my IC-735. At the time there weren't any ready made interfaces, so I built my own. I initially tested it using HRD, but it didn't work. It was a long time ago, but I think the message was similar to the one you are getting. I fussed around with it for several days. I swapped out the USB to Serial Port converter, but that didn't help. Finally, after trying a bunch of different adapters, I added a Null Modem adapter. Once I did that, HRD immediately connected. So the only thing wrong was that, I had the RX and TX pins swapped.
     
    KA9JLM likes this.
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    Good point. T and R data may need to be swapped.

    Some serial to USB interface adapters have a driver setting for connecting to a DTE or DCE Device.

    It may be a simple driver setting.
     
  7. K4VMG

    K4VMG Ham Member QRZ Page

    I wish it was, I've tried virtually ever combination but most people seem to think this works out of the box.

    Piexx are apalling, I've tried emailing and calling but zero repsonse. I've probably going to have to go through credit card to get my money back
     

Share This Page