Are 3-500Zs happy glowing?

Discussion in 'Amateur Radio Amplifiers' started by G3YRO, Nov 21, 2019.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Subscribe
ad: L-MFJ
ad: Left-2
ad: l-BCInc
  1. K9ASE

    K9ASE XML Subscriber QRZ Page

    I just put in Taylor graphite tubes and have yet to see them glow. I was told that graphite tubes don't glow.
     
  2. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    I doubt that had anything to do with glowing. Probably bad vaccum and they got gassy. Making the anodes glow red doesn't accelerate that.

    I have RFP (Chinese) tubes here, last set lasted ten years of nearly daily use including getting them very red almost every use. I'm not sure if "Taylor" and "RFP" branded are really any different, although possibly they're "selected."
     
    WG7X likes this.
  3. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    They do.

    Mine are all 3-500ZGs with graphite anodes and they glow just fine. Depends on use.

    To really make them glow, try AM.:)
     
    WG7X, WA7PRC and K9ASE like this.
  4. N2EY

    N2EY Premium Subscriber QRZ Page

    Read the data sheets to be sure.
     
    K9ASE and WA7PRC like this.
  5. NB4R

    NB4R Ham Member QRZ Page

    My graphite tube glow just as much as the previous 3-500zs did.
     
  6. G0GSR

    G0GSR Ham Member QRZ Page

    Not high enough to make a pair of 500's glow ;-)

    Frank
     
    N2EY likes this.
  7. WA9SVD

    WA9SVD Ham Member QRZ Page


    And if white or blue,:eek: EVACUATE immediately!:rolleyes:
     
  8. W5UAA

    W5UAA Ham Member QRZ Page

    Ya, I didn't glow any amp tubes when I was G0GZH either. <wink>
    When I was HL9GN, I told the customs inspector it was a 2KW receiver preamp. But I didn't glow it there either. <wink>
     

Share This Page