Anyone running Thetis with Anan 7000dle mkII?

Discussion in 'Software Defined Radio (SDR)' started by AG5CK, Nov 3, 2019.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: Left-2
ad: L-MFJ
ad: abrind-2
ad: Subscribe
  1. AG5CK

    AG5CK Ham Member QRZ Page

    I have tried loading protocol 2 firmware into the rig several times with no luck. The bootloader goes through the process as it should, but Thetis and sdr console V3 will not work. When I click the power button in Thetis I get an error asking if the hardware is powered on and connected. I use the bootloader to go back to protocol 1 and all is good.

    I have successfully installed protocol 2 with the hpsdr bootloader and used Thetis with an anan 100 but no joy with the 7000.
  2. N3LK

    N3LK XML Subscriber QRZ Page

    I just purchased the ANAN
    N3LK NOTE ->> Just purchased 7000dle mkII and installed protocol 2 (which required me to install a missing DLL file which could not be "legally" included in the protocol 2 install kit). After adding the missing DLL file P2 worked fine and loaded Thetis 2.6.8 . . . works great! Simon's SDR 3.0.16 also works fine! The "missing file" problem has been documented and requirement should be flagged when loading P2. Also, suggest using the bootloader with direct LAN connections.
    AG5CK likes this.
  3. AG5CK

    AG5CK Ham Member QRZ Page

    Thanks. I didn't find any documentation about a DLL file. I did find that WinPcap had to be installed and they could not legally put it in their installer. I did install WinPcap back when I was messing with the anan 100. I also read that protocol 2 does not play with all serial numbers of the same model. I am using the boot loader and a direct ethernet connection to the pc.

    Did you set up a static ip address for the anan or just plug it in and go? I have not successfully done this either. I wonder if that could have something to do with it? I'm in over my head here and trying to eliminate as many things as possible. :)
  4. KD8TUT

    KD8TUT Ham Member QRZ Page

    One of the shortcomings of the ANAN ecosystem is documentation. It's really the only shortcoming I've encountered. The pcap requirement is noted on the HPSDR site here:

    A link at the bottom of that page takes you here:

    That's where you can find the firmware files.

    As far as compatibility, I think the timing issues are only with ANAN 100D models.

    Well, I assigned my radio's IP with a DHCP reservation on my router. So it's static- but I didn't need to set it on the radio. Can't think of any advantage to a static IP- other than always knowing where the radio is in IP land.

    One disadvantage of a truly static IP (setting it on the radio) comes from changes to the network or moving the radio to another network- it may become unfindable since it will not query the DHCP server for a new IP.

    So use a DHCP reservation. That way if you replace a router and the IP range changes or you move it to a friends house to use it the radio will always be findable.

    HOWEVER: If you are running a smart, managed switch, you may have problems. I don't think the discovery protocol works properly in some cases. It's best to put the radio and controlling PC on a "dumb switch". Most home routers are have a unmanaged switch built into them. A cheap switch from the local computer store will be unmanaged. Think something like a Dlink, Netgear, or TP-Link 5 or 8 port switch.

    Don't get discouraged. These radios will help you up your game in the computer and networking area while providing an excellent radio experience.

    It's worth the pain- and there are no stupid questions.
    AG5CK likes this.
  5. AG5CK

    AG5CK Ham Member QRZ Page

    That is where I found the note about pcap and where I have been getting the firmware files. The anan is connected directly to my pc and that pc connects to the internet via wifi. Either the process for uploading firmware is different a 100 and 7000 or this rig just isn't going to work with Thetis and P2 at this time. I have used Thetis and P2 with my 100 but it wasn't fully functional. RX and TX was fine. No fwd or ref power meter so the swr meter and puresignal did not work. I have went through the same process with the 7000 (with the respective firmware) but it's a brick with protocol 2 firmware installed. If I'm being dense someone give me a slap on the back of the head.
    Last edited: Nov 3, 2019
  6. KB1YFD

    KB1YFD Ham Member QRZ Page

    I have an anan 7000DLE S/N 13 and am running Thetis ver 2.6.8 d6_2. Here are the links to the files I used.

    This last link is to a ZIP file containing .DLL and the Thetis.exe file. Just unzip them and drop them into the working folder. On my win10 PC it's C:\Program Files (x86)\OpenHPSDR\Thetis

    Best of luck, John KB1YFD
    AG5CK likes this.
  7. KB1YFD

    KB1YFD Ham Member QRZ Page

    Here is protocol 2. I had to add metis to the name for the bootloader to work. John KB1YFD

    Attached Files:

  8. AG5CK

    AG5CK Ham Member QRZ Page

    Thanks. I have been having to change the name to metis also. All is good except for the dll file. The link was a dead end.

  9. AG5CK

    AG5CK Ham Member QRZ Page

    A new Ethernet cable solved my problem. Apparently Thetis requires a gigabit connection to work. The light on my PC Ethernet port was green indicating a 100 Mbps connection. I tried a new cat 5e cable, the light changed to orange and Thetis is working. The old cable is also labeled cat 5e so I'm not sure why it didn't work. Thanks to everyone for helping.

    I also checked the rig for a missing jumper that can cause an issue when updating firmware. Apparently a couple of units got shipped without a jumper installed on J14.
  10. KB3BF

    KB3BF Ham Member QRZ Page

    Thanks everyone for all the posts.
    For sure the ANAN involves continuous learning.

    I tried to save some dough after getting a used ANAN 7000DLE (P2, + latest Thetis) by using a 2015 NUC Celeron.
    Even though new BIOS was installed, NUC came with 8GB DDR3 RAM, and 256GB SSD I could only run one Thetis Rx ADC channel.

    The CPU was already at 100% capacity and crashed from time to time. Turned out I had only a 100Mbs NET Switch, so I replaced it for a 10X faster one but nothing changed.
    Turns out that while the ANAN 7000DLE connects at 1Gbs, the NUC remains stuck at 100Mbs, even after changing cables and resetting the BIOS battery.
    Then it was noticed the NUC had WIN7 32bit OS, which means it was useless to have 8GB of RAM. Upgrading to WIN10 64 bit OS did not help.
    Not sure what sets the connection speed at 100Mbs. Bios, OS ?

    Bottom line: this NUC Celeron will not work with the ANAN 7000DLE.
    Sooo I am back to square-one looking for a better NUC. At least the older NUC is still good for streaming video......
    If anybody has any suggestions or info on what they are using I would be happy to learn more.

    chris kb3bf

Share This Page