Ameritron 811H amp no grid current issue.

Discussion in 'Amateur Radio Amplifiers' started by K7HN, Dec 7, 2019.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-2
ad: MessiPaoloni-1
ad: Subscribe
ad: Left-3
  1. K7HN

    K7HN Premium Subscriber QRZ Page

    Hello,

    I have an Ameritron 811H amp. Using 4 811A tubes. Arb 704 hooked up properly. No ALC line hooked up. My frequency pre-tuned to 1.2:1 SWR. Plate Voltage is fine at 1700Ma. In CW mode with no load, key the exciter to tune up the amp. No grid current at all. Checked, rechecked and triple checked all connections between Flex 6300, amp, MFJ 986 tuner and ARB 704.

    LED’s light on both the 704 and the 811, plate voltage drops as it should but no movement at all on the Grid Meter. Made sure I’m tuning properly on CW, then AM, then tried FM. In all cases the plate voltage drops, LED’s light, but no Grid Current reading. Showing a photo of all tubes before I installed them into this used amp for reference. All tubes seated and connected at the caps.

    Any helpful suggestions would be much appreciated.
     

    Attached Files:

  2. WB2WIK

    WB2WIK Platinum Subscriber Platinum Subscriber QRZ Page

    What's the plate current (Ip) indicate?
     
  3. MM0IMC

    MM0IMC Ham Member QRZ Page

    Any signs of power out? The voltage drop would suggest there is some power consumption somewhere it the chain...
     
  4. KH6AQ

    KH6AQ Ham Member QRZ Page

    You can check the grid current circuit without removing an components. Unplug the amp, make sure the HV meter shows zero volts, remove the cover and short a plate cap to the chassis (I use a screwdriver). The components are on the circuit board near the meters and all components are on the top side.

    R11 (180 ohms) in circuit it will read lower than 180 ohms
    Grid current meter (M2) should deflect when an ohmmeter is connected to it
    D16 check with an ohmmeter to see if it's shorted
     
  5. K7HN

    K7HN Premium Subscriber QRZ Page

    Thanks a lot guys. I appreciate your help a lot.
     
  6. KM3F

    KM3F Ham Member QRZ Page

    What does 'in cw with no load' mean?
    Regardless of grid current or not, how much drive and what did the power meter show.
    This would indicate a grid current circuit fault only.
     
  7. K7HN

    K7HN Premium Subscriber QRZ Page

    Load=power. Per Ameritron instructions turn on exciter with no power. I meant I’ve used CW (at no power and at up to 10 watts) as well as FM and AM modes my friend.

    Thanks for any help you can give me.
     
  8. K7HN

    K7HN Premium Subscriber QRZ Page

    Lol. Got it fixed. Thank you everyone for your help! I should’ve quadruple checked everything LOL
     
  9. K7TRF

    K7TRF Premium Subscriber QRZ Page

    Good job figuring it out.

    What did you do to fix it? It helps to post what you found so other hams with similar problems that land here after a Google search can learn something.
     
    W4NNF and W1TRY like this.

Share This Page