AEA PK232MBX SETUP HELP NEEDED

Discussion in 'Working Different Modes' started by GM4BRB, Nov 7, 2010.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: L-MFJ
ad: Subscribe
ad: Left-3
  1. GM4BRB

    GM4BRB Ham Member QRZ Page

    I've not used a PK232 before. I've been using an old AMT-1.
    There are "well documented" issues around the three wiring standards for the 25-D to 9-D serial connections. I have as most people for this gear do, the EIA232 (25-D) to EIA574 (9-D) cable (that is home-brewed, I didn't get the orig connector).

    I have two DOS programs, PAMS2 by W5SMM and Pakratt II for DOS.
    Pams works fine as far as I can tell with the cable I built.

    After much unsoldering and resoldering I ended up forgetting which combo of pins 3-2 and 2-3 for TD and RD I had but currently have 3-2 from DTE (laptop) and 2-3 for the PK232 (DCE) and probably should stick to 4-8 RTS and 5-7 CTS. I've also tried disconnecting the RTS, CTS, DTR and DCD cables completely just sticking to TD & RD. But this doesn't fix my problem

    Because of the initialisation problems when changing programs, autobaud and all that, I can only use one program PAMS or PAKRATT at any one time. But when I do reinitialise and start PAKRATT I get the BAD message for my COM1 Port. It doesn't seem to function with PAKRATT fully,

    Sure the software of pakratt accepts some commands but none seem to make it across the RS232 cable to actually make anything happen on the PK232. But all is fine when I use PAMS, which has its own Maibox BIOS software MBBIOS.COM in the program. PAMS auto-configures a MODEM automatically at setup and works just in AMTOR. I need to get access to all the modes of hte PK232 of course, so I'm trying the old PAKRATT II software.

    Could it be something to do with the PK232MBX firmware? I have version 7.0 and I did just once after hours of trying, get the ROM version readout (status message) on the Laptop. But only once. I can input MYCAL, HBAUD, and other commands but I don't think I am communicating with the PK232MBX using Pakratt.

    I've tried following the full manual instruction, I have the full manual and have set everything up. When I enter my AAA, setup MYCAL I try to connect using C AAA but eventually get a timed out & DISCONNECTED message.

    But the give away is the single 'BAD' message I get during initialisation that seems to refer to the COM port, hence the RS232, but as I said this seems to work fine with other software in AMTOR mode.

    Very confusing.

    Anybody any experience of this and what I'm most probably doing wrong, if it is me.
     
  2. GM4BRB

    GM4BRB Ham Member QRZ Page

    Thing is, I'm reconstructing a vintage Datacomms setup, that's why I don't have all the modern PTC-II's and such.
    Well I got it to reply to the * symbol and give me a v7.0 firmware readout no problem. Does it first time every time from CMD: But, Still gives me a BAD com port and 'connect the PK232 to a proper port' message. A proper port?

    So, I tried it on a different computer, same result. Odd, for sure. The COM port works fine when it is configured by an external program and not internal firmware.
    Shame about that.

    Anybody got a v7.0 firmware for later PK232MBX (serial number 12142) they can spare or copy?

    How very infuriating, what!
     
  3. AG3Y

    AG3Y Guest

    Have you tried just a simple null modem cable ( no RTS CTS hooked up ) Just cross over the RD and SD lines, and data ground to each end of the cable, and let us know what kind of results you get.

    If you set your com port baud rate high ( 9600 or 4800 ) you should not need RTS CTS . The data will flow much faster between the laptop and the PK-232 than it is either being sent out, or received from your radio.

    Have you tried hitting the * key several times, until the software ID message comes up? That should match your PK-232 and laptop baud rates.

    Whoops, I see some additional info got posted as I was preparing this. Have you tried just using a "dumb terminal" program with the box?

    There is also a DOS command "Set" IIRC, it goes: set com1 96,n,8,1 <enter> What happens when you do that? You might need to incorporate it into a batch file.
     
  4. GM4BRB

    GM4BRB Ham Member QRZ Page

    Thanks for the help. I've managed to fix it all I think. Typical of the male of the species I have omitted to read the full manual, - Properly.

    I hadn't rigged up the radio cable with the two wires twisted together for the first stage test, since I don't have the radio connected yet (I'm just running tests with software). Also I had a pre-used RS-232 cable that had Signal Ground connected to Shield/Frame Ground. But I notice that I also probably had TD RD the wrong way round because of the confusion over the various ways of wiring up.

    RTS goes to RTS, CTS to CTS and signal ground floats as it has -I0v digital on it.

    The 'BAD' Message came form not figuring out how to save the PK232 and Pakratt paramaters in the Files Menu. So, that explains everything. But also It's really down to finding the objectivity and renewed energy to tackle all the little details.

    'Wait until the time is right' is my motto. And that time just came and went. So I'm now looking forward to building the Mic cable using this vintage gear soon.
     
  5. WJ6R

    WJ6R Ham Member QRZ Page

    Keep in mind, your Pakratt for DOS has a YK2 issue in it, since it's was made in the last century. On the 25th Anniversary CD we have a version that is Y2K compatable, as well as PakRatt for Windows and our ROC software.
     
Thread Status:
Not open for further replies.

Share This Page