ad: elecraft

30L-1 - Tuning Cap squeel?

Discussion in 'Amateur Radio Amplifiers' started by KJ7MX, May 17, 2020.

ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Left-3
ad: Subscribe
ad: abrind-2
ad: Left-2
  1. KJ7MX

    KJ7MX Ham Member QRZ Page

    I've been working through a 30L-1 I inherited and have replaced the HV board and installed new Cetron tubes. It worked fine - loaded like it should with 500+ watts out on all bands. I didn't use it for a few months but put it back in line a few days ago. I ran through the testing on all bands and when I got to 15m it would start doing this faint "squeal". This is happening when the bandswitch and tuning control are set to 21Mhz, with the amp at idle & transit not engaged. I switched to 28Mhz and it does the same thing there when I tune the "tuning cap" past the 28Mhz area. If I move the tuning control away from the corresponding band, the squeal stops.

    So, this is happening with the amp idle, transmit not engaged. I didn't attempt transmit on these two bands. When this faint squeal starts, it throws a strong noise level into the connected transceiver. I did some cleaning on the relay this morning and didn't see anything that looks corrosive or dirty. I did see the grid resistors are due for replacement, however I doubt that's the issue.

    Anyone have thoughts on this one?
     
  2. G0JUR

    G0JUR Ham Member QRZ Page

    does it draw current when squeeling? could be parasitic oscillation
     
  3. W1QJ

    W1QJ Ham Member QRZ Page

    Those amps are known for low frequency oscillations. Check the parasitic suppressor resistors, they could be cooked and way out of spec. The one I’m working on right now had one at 750 ohms. But this problem is known.
     
  4. KJ7MX

    KJ7MX Ham Member QRZ Page

    I did some more reading and think the parasitic oscillation is where it will end up. I don't know why it decided to develop it now when it was fine before, however with that said this one had been run hard. Since 2 of the 4 grid resistors have been overheated and I'll be doing those anyway, I ordered the 100 ohm 2W resistors to build new suppressors.

    Thanks for the input!
     

Share This Page