View Full Version : VX-Commander keeps resetting VX-7R

03-29-2010, 02:51 PM
Morning all,
I just purchased a new Yaesu VX-7R, and based on the rave reviews I've found on the Internet, I obtained a copy of the VX-Commander software from KC8UNJ's website. After reading some brief instructions I found on another ham radio web site, I purchased the USB to 4 pin plug made by Kawa on eBay. I went through the cable loop-back test that KC8UNJ recommended and the cable passed the test. I then tried to download the VX-7R to VX-Commander and the link up was completely successful. All of the settings and frequencies I manually entered into the radio came up in VX-Commander.

My problem occurs when I try to enter in some new data in the software and upload everything BACK to the radio. Obviously, I have the correct port set in the software, but after about 8 seconds of data transfer time (according to the software), and after about 15 seconds of sitting there, the radio comes back with a "Clone Error" message. I followed the brief instructions in the troubleshooting guide that came with the software about slowing down the data transfer to the radio based on the error message coming up... but regardless of the "time-delay" I choose, the upload is still in the neighborhood of 8 seconds and the radio still comes up with the error. OR...it will come back with a display that indicates that it has reset. On the 440 side, the frequency is reset to 430.000 and on the 2-meter side, the frequency display say "EEE.EEE".

I've tried a dozen times to figure out what's wrong...but having to manually reprogram the radio after each attempt is a pain.

Does ANYONE have any clue what the problem could be? This is really frustrating to say the least.

Best 73s folks and thanks so much for taking the time to respond.

Aaron (N2HTL)

03-30-2010, 03:18 AM
Pretty sure this applies to the VX-7 as well as my VX-6.

The cable is a 4-pin phone jack, but with a screw-in portion. If it is not screwed in ALL THE WAY, I get the same results you do. Try screwing in another full turn or so. You may have to trim the plastic around the screw threads on your programming cable if that gets in the way.

03-30-2010, 03:43 AM
Thanks very much for the response. I was wondering about that myself. I had actually torqued the plug in so tight that I needed to use pliers to grab and twist to remove the plug. The plastic portion of the plug seems to be perfectly flush so that it doesn't seem to prevent the plug from going in as far as it needs to. What I AM curious about are the threads on the plug itself. I have heard that it may be necessary to grind the threads off the plug... but only to make it easier to take the plug in and out. Is it possible that the threads are preventing the plug from going in as far as it needs to? Finally, wouldn't the plug not being seated properly also prevent data from being read from the radio to the VX-Commander software? That part of the operation worked just fine.

Here's hoping you can shed some more light on the subject before I try it again. After dozens of tries... and having to reprogram the radio after every attempt... you can hopefully understand why I'm gun-shy about trying this again. :-)


03-31-2010, 03:35 AM

On my VX-6 I evidently tightened too tight one time, and had a heck of a time getting the plug back out. My cable is the one Yeasu sells, so I can't comment on yours, but filing the threads off sounds a bit extreme. And then how would you know that the plug is not in too far?

My best suggestion is to find someone in your local area with a VX-5/6/7 that has a working programmer and try that. Then if it works, modify your cable to match. The local clubs are a good place to find someone with compatible equipment.

I bought a VX-8 recently, and the programming cable is more like a DIN plug, much less problems with that setup. I avoid reprogramming the VX-6 as much as possible.

03-31-2010, 03:09 PM
Have you checked to see if the memories are actually being written, in spite of the 'Clone Error' message? I know that sometimes happens with my VX-5. The memories are written just fine, but we get that error. I think I've also seen it when the file with the data to be written was not exactly what the program expected.

04-01-2010, 02:28 AM
Yes, I've checked. Two things happen when I try to upload data back to the radio...but there doesn't seem to be any pattern to either one of them.

Let's assume that I've got a fully programmed radio with memories 1-10 filled, 20-30 filled, and 40 filled. I've got the strobe turned off for receive, the VFO set for 5 mhz, many of the memories set to be ignored during a scan, and so on. In other words, by manually programming the radio, I've got it configured so it's fairly comfortable for me to use.

I can hook up my cable and successfully download ALL of that data to VX-Commander... and once the download is completed, the program shows ALL of my memories and all presents as they appear on the radio.

The next logical step is to make some frequency additions to the VX-Commander database so that I upload the new additions (or chages) BACK to the radio. By following the prompts the software provides, I put the radio in "Clone Wait" mode and click "OK" on VX-Commander. The "Clone wait" message turns to "Clone RX". In 8 seconds or less, the progress bar in the software indicates that the data has transfered, and the status in the lower left corner of the screen displays the upload stats and all seem to have uploaded to the radio successfully.

After about 15 to 30 seconds, the radio does one of two things. The "Clone RX" message displays "Clone error" and simply hangs on this message with no change... or the "Clone RX" message goes away and the display on the radio returns but NOT with my settings and frequencies intact. Basically, the screen that appears shows "430.000" mhz with some other information that is NOT what I programmed. If I hit the main or sub buttons, the 2-meter frequency is NOT displayed. Instead I see "EEE.EEE". In reviewing all of the settings and memory frequencies I programmed before I attempted to upload back to radio, I find that everything is gone.

Hope this helps to better describe my problem.

Thanks again!

Aaron - N2HTL

04-01-2010, 01:25 PM

I read that the loop-back test was good, but that cable is still the weak link if you have followed the various threads that deal with any radio programing that have SERIAL ports and computers that only have USB port.

There are a couple of different chip sets and one is preferred over the other. Also the drivers for different versions of the operating system can be a issue.

I have an Edgeport/2 and Edgeport/4 that have worked for me and the many radios I have used it with. My first HT was the VX6 using VX Commander and I had no problems. Edgeport is pricey and both of mine are discontinued so drivers for new op system are a problem.

04-01-2010, 03:06 PM
I have the same cable and radio and mine works fine.

I have not tried that loopback tester but I will give it a try tonight when I get home.

I will let you know what I find out.


04-01-2010, 04:43 PM
Check the Commander help file. There is at least one known issue which sounds similar to your problem. I had my 7R get screwed up with commander, and following the help file was able to fix it.

good luck

04-01-2010, 11:58 PM
Ok, I tried the loop back test and it worked. I made some changes to my radio while I was at it and it worked also. I know you did not want to hear that.

Here is the snippet from the help file.

If the write seems to go OK at first (CLONE RX for a while), but you eventually get a CLONE ERROR, or current programming is lost when trying to write:

On some PCs, the software routine that writes to the VX-7 is executing too fast, and the VX-7 cannot receive the data quick enough.


To slow down the write routine:

Go To Settings > Port.
Click the "!" button. This will display the Write Delay dialog.

The default value is 15. Try higher values to make the write take a little longer (17,20,25).
Increase the value a little, and try to write to the VX-7 again.
Very high values will cause corruption or a clone error. However, the VX-7 seems very tolerant of slower write times.

The time it takes for a write operation is displayed in the status window after all of the data is sent. Usually, for reliable writes to occur every time, the write should take 35-40 seconds.

Good luck,


04-02-2010, 04:56 AM
Thanks for the reply Jon. I found this portion of the help file almost immediately after I had the settings and memory wiped out the first time. I changed the "speed" of the data from 25 - 30 and it had no effect. I even went to the extreme and set the speed to something ridiculous like 200 and again, no effect. If you look in the lower left corner of the Commander screen, you'll see the status of the program. My copy always reports that the data upload transfer takes about 8.6 seconds - give or take a few. The status bar - which indicated the data transfer - never seems to slow down no matter what speed I change the data upload rate to.

I don't know if I mentioned this before to everyone, but the cable I'm using is the USB version and NOT the RS-232 version. I'm wondering if there's a way to slow down the data transfer on the COM port the cable is on from within the computer itself and not the Commander software.

Now what's this I hear about the data transfer not working if the volume is turned down?

Thanks for hanging in there with me on this one. I really appreciate it.


04-28-2010, 03:44 PM
HELP please,

1) The file I loaded had about 260 entries in it. All I was able to get using the V/M button was one freq. 144.00. Not sure why that is. It took 52 seconds to load the file into the HT.

Using Commander, I read from the HT and got only 1 frequency from the HT. I 44.000 was the only frequency in the MR area of the HT. I assume that the load did not work. When the transfer from my laptop completes and I see the message that it was successful. Is there something I need to do to save the information in the HT? My commander screen seems longer vertically than necessary. I see a completion message but can't see if additional instructions are below the message. I think I am almost there or at least I hope so. Any idea why it completed but no memories are stored. I am using Vista Home Premium OS.

2) I keep seeing mention of the Commander User/Help Manual. Where in the world can I find one?



10-06-2010, 02:31 AM
Has anyone discovered a solution to this?

I'm seeing the same behavior with the VX-7 Commander software. I'm using a newer VX-7R, Yaesu's own (really RT Systems' own) cable from the ADMS-1G package, and I'm able to read from but not write to the radio using VX-7 Commanded. If I attempt a write with VX-7 Commander, the radio either instantly returns to the "standard" VFO display screen with the memory wiped while VX-7 Commander merrily draws the progress bar like the process is working or the whole process actually appears to proceed correctly but after "completion" the radio returns to the "standard" VFO display screen with the memory wiped.

I can successfully write to the radio with the ADMS-1G VX-7 Programmer software, so the hardware side of things is working.

10-06-2010, 04:27 AM
I really wish you guys will find out the ' glitch ' resolve !
The suspense is killing me . Seriously ! I found , on another brand of radio , that the driver was the issue . The OS was supposed to be XP and Vista did not work . My radio did EXACTLY what you are describing ! :(

Sorta stinks . :(


10-06-2010, 04:31 AM
Actually, I managed to keep plugging away at it. Changing the Write Delay, as detailed in post #10 of this thread, caused it to start doing different things. Trying different delays one by one, I discovered that the "magic number" for my radio is 30. With the Write Delay set to 30, the Commander software can consistently write to the radio without problem.

11-01-2010, 09:22 AM
Did you guys remember to take a reading from the radio first? The software needs to learn exactly what radio you have.
Take a reading of the radio. Then without closing the software select "Open" and open your saved file you wish to download to your radio. You will find you need to do this after a reset or writing to another radio.
Works every time for me.



11-24-2010, 11:43 PM
I had a similar issue. VX-7 Commander worked great for several years. When I went from 54 to 56 memories it would appear to work fine, and then after a few seconds after it seemed to complete the upload I got a "Clone Error" message.

Going to "Settings" -> "Port" -> "!" and changing from 15 to 17 took care of the problem

11-28-2010, 01:08 AM
Did you guys remember to take a reading from the radio first? The software needs to learn exactly what radio you have.
Take a reading of the radio. Then without closing the software select "Open" and open your saved file you wish to download to your radio. You will find you need to do this after a reset or writing to another radio.
Works every time for me.



This is what worked for me!
also went to 17 on delay butthe key was saving and opening without closeing commander

Thanks again mars mod works killer

ad: dxeng