Callsign
ad: dxeng
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Kenwood TS-940S keypad frequency entry problem.

ad: L-HROutlet
ad: l-assoc
ad: l-tentec
ad: l-rl
ad: l-gcopper
ad: l-innov
ad: l-WarrenG
ad: l-Waters
  1. #1

    Default Kenwood TS-940S keypad frequency entry problem.

    When entering the frequency digits using the keypad, they show up in the main display as entered. However, when I then hit the ent(er) key, the display and VFO reverts to the previous frequency that was in use. Where should I start looking? I have replaced all batteries.
    Thanks,
    Ron, N8EBN

  2. #2

    Post

    Kenwood TS-940 BIBLE, Jeff King ZL4AI / DU7
    http://homepages.ihug.co.nz/~jaking/TS-940_02.htm

    Here is a PDF version, 151 pages of How To, DIY, repairs, etc.
    http://gatorradio.org/Manuals/Kenwoo...es_Reviews.pdf
    Nullius in verba

  3. #3

    Default

    Thank you for the links. I read through all the entries in the bible but found no discussion of this particular problem.

  4. #4

    Default

    Check out the memory cell battery, it is likely depleted.


    73

  5. #5

    Default

    When entering the frequency digits using the keypad, they show up in the main display as entered. However, when I then hit the ent(er) key, the display and VFO reverts to the previous frequency that was in use. Where should I start looking? I have replaced all batteries.
    Problem same before battery replacement?
    http://www.beevo.com/TS940%20Battery%20Replacement.html

    The TS-940S has TWO lithium coin cells, CR2430 with solder tabs. You changed both?
    Did you observe correct polarity?

    Potential lithium coin cell replacements w/tabs (~ $2)

    Digi-Key
    P025-ND : BR2330A/FAN
    P654-ND : BR2330/F3N
    P657-ND : CR2032/F2N

    =
    INTERIOR PHOTOS of TS-940S
    http://www.beevo.com/Kenwood%20TS940%20Images.html
    Last edited by W9GB; 03-14-2013 at 12:25 AM.
    Nullius in verba

  6. #6

    Default

    Quote Originally Posted by KE3WD View Post
    Check out the memory cell battery, it is likely depleted.


    73
    Yes, I have replaced all three batteries, the two behind the sub-display, and the one under the speaker base.

  7. #7

    Default

    Quote Originally Posted by W9GB View Post
    Problem same before battery replacement?
    http://www.beevo.com/TS940%20Battery%20Replacement.html

    The TS-940S has TWO lithium coin cells, CR2430 with solder tabs. You changed both?
    Did you observe correct polarity?
    Potential lithium coin cell replacements w/tabs (~ $2)

    Digi-Key
    P025-ND : BR2330A/FAN
    P654-ND : BR2330/F3N
    P657-ND : CR2032/F2N

    =
    INTERIOR PHOTOS of TS-940S
    http://www.beevo.com/Kenwood%20TS940%20Images.html
    Yes, the problem was the same before the battery change. I assumed it was a battery problem but I guess it wasn't. I also replaced both batteries behind the sub-display, and the one under the speaker base plate. Correct polarity was diligently observed.

  8. #8
    Join Date
    Jan 2006
    Location
    florida usa
    Posts
    2,412

    Default

    940's are famous for developing bad connections,... try to disconnect and reseat all internal elect connectors.

    be careful

  9. #9
    Join Date
    Jan 2000
    Location
    Commerce MI (Detroit area)
    Posts
    8,230

    Default TS440s keypad troubles

    I had problems with the keypad entering multiple # s or nothing on my TS440s.
    Tap the 5 key and 5555 appeared on the display, tap 6 and nothing appeared, etc....After many attempts it started working better,.
    I played with the key entry a few times when I first got my used 440 and ignored it for ten years, until 60M opened up.
    I wanted to program the 60M frequencies when CW was allowed and it took me hours to get the 10 channel frequencies entered.
    May be disuse let the key contacts oxidize up ??
    Now when I want to get on 60M I just hit the MEM/VFO button and go.
    Last edited by K8JD; 03-15-2013 at 11:05 PM.
    73.....JD, FISTS #3853,cc 455,SKCC # 1395,tribune #12,
    Official US Taxpayer

  10. #10

    Default

    Thanks. I'll try that next.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •