Callsign
ad: Waters-2
Page 5 of 11 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast
Results 41 to 50 of 110

Thread: TS-820S Doesn't Power Up

ad: L-HROutlet
ad: l-assoc
ad: l-tentec
ad: l-innov
ad: l-rl
ad: l-BCInc
ad: l-gcopper
ad: l-AmericanRadio
ad: l-Waters
  1. #41

    Default

    Make sure and run the switch in several directions immediately after applying the WD-40.

    Glen, K9STH

  2. #42
    Join Date
    Jan 2011
    Location
    Houston Texas
    Posts
    4,584

    Default

    Quote Originally Posted by K9STH View Post
    Make sure and run the switch in several directions immediately after applying the WD-40.

    Glen, K9STH
    That is a must do.

    I don't think WD40 is the same as it used to be.

    I have used WD40 on many TV tuners in the day, but have found better stuff to use now a days.

    The Over Spray is not good if the spray tube is used. I use Q-Tips.
    "Theory only works perfect in a vacuum." KA9JLM Don

  3. #43
    Join Date
    Jan 2011
    Location
    Houston Texas
    Posts
    4,584

    Default

    Quote Originally Posted by KF5IYL View Post
    I'd never thought of using WD-40 for contact cleaning. I just put a small amount in the contacts, and I'm going to wait until I'm sure it's dry before I try to power it on. I'll keep y'all updated on what happens!
    You may be waiting a while for it to completely dry out, Weeks.

    Crank it up and give us a report.
    "Theory only works perfect in a vacuum." KA9JLM Don

  4. #44

    Default

    Quote Originally Posted by AF6LJ View Post
    If it receives it should transmit.
    You've obviously never owned an Icom 746!

  5. #45

    Post

    Any tips for cleaning it, or is it just like any normal rotary switch?
    Q-Tips doesn't take much solvent.

  6. #46
    Join Date
    Nov 2010
    Location
    Texas!
    Posts
    59

    Default

    Hmmmmmmm. . . Still isn't working. . . And, now I can't reproduce what I did earlier by fiddling with the band switch. . . Sorry to keep bothering you guys, but any more ideas? Or should I let the WD40 dry longer?
    [I]"Donít let anyone look down on you because you are young, but set an example for the believers in speech, in conduct, in love, in faith and in purity." [/I]- 1 Timothy 4:12

  7. #47
    Join Date
    Aug 2008
    Location
    SanDiego, People's Republic of California FEMA District 9
    Posts
    35,620

    Default

    This is what we are here for, to help.
    "I would rather be free than rich."
    Dick Gregory

  8. #48
    Join Date
    Jan 2011
    Location
    Houston Texas
    Posts
    4,584

    Default

    Quote Originally Posted by KF5IYL View Post
    Hmmmmmmm. . . Still isn't working. . . And, now I can't reproduce what I did earlier by fiddling with the band switch. . . Sorry to keep bothering you guys, but any more ideas? Or should I let the WD40 dry longer?
    Did you clean the contacts in the RF PA cage also ? Be careful of the high Voltage.

    You may want to clean the CAR control as well as the other controls.
    "Theory only works perfect in a vacuum." KA9JLM Don

  9. #49
    Join Date
    Nov 2010
    Location
    Texas!
    Posts
    59

    Default

    Yes, but I didn't do the CAR contacts. I guess I'll go clean those now.
    [I]"Donít let anyone look down on you because you are young, but set an example for the believers in speech, in conduct, in love, in faith and in purity." [/I]- 1 Timothy 4:12

  10. #50
    Join Date
    Nov 2010
    Location
    Texas!
    Posts
    59

    Default

    Still nothing.
    [I]"Donít let anyone look down on you because you are young, but set an example for the believers in speech, in conduct, in love, in faith and in purity." [/I]- 1 Timothy 4:12

Page 5 of 11 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •