Callsign
ad: CQP123-1
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Serial Port - Access Denied

ad: L-HROutlet
ad: l-assoc
ad: l-innov
ad: l-gcopper
ad: l-WarrenG
ad: l-tentec
ad: l-rl
ad: l-Waters
  1. #1

    Default Serial Port - Access Denied

    I have an Icom 718 and planned to use the CI-V (CT-17) level converter to control the transceiver from the computer. Problem is the computer will not let me access the serial ports (COM1 or COM 2). I keep getting an “access denied” message when I try to connect to it through Ham Radio Deluxe. I removed every fax, mobile phone or PDA program I could find on the hard drive thinking one of these programs was holding the ports open. I even purchased a serial to USB cable which created a COM 3 port and access was still denied. I’m out of ideas, anybody else have this issue?

  2. #2

    Default

    You haven’t given much information to go on.

    Does your computer have real serial ports, or do you only have USB ports?

    What is your operating system?

    Is your C-17 the Icom C-17 level converter or are you using an aftermarket one?
    Hopefully you didn’t pay the ridiculous price that Icom wants for the C-17, there is a number of aftermarket ones that work fine for about $13.00 shipped to your door available on eBay (I use this one).

    Have you tried the ‘Auto Detect’ for Com port and Speed listed in the dropdown boxes in the Connect window of HRD?

    If it’s a USB interface, then it may be assigned a COM port above 4, check in the ‘Control Panel > System > Device Manager’ to see what Com ports you have available both before and after plugging in the USB cable. The one that appears after plugging in the cable is the Com port you want to use. HRD will recognize Com ports up to 256.

  3. #3
    Join Date
    Oct 2004
    Location
    Jacuzzi
    Posts
    11,732

    Default

    In the device manager you can change the settings of the comport.

    The problems with comports is that all devices you attach to your serial port must match in terms of the baud rate settings and flow rates or any error correction protocals assigned to them.

    From the control panel go to "system" and then in System find the "device manager" on your PC.

    In the device manager you will be provided a list of devices.

    look for (Ports COM & LPT) and expand it. Choose "Communications Port (COM1)" or (COM 2 etc... and click on it.

    This will bring up some tabs. Select the tab called "Port Settings"

    As I mentioned earlier these "settings" must be configured equally to the device that is attached to the serial port. (You need to know the "communication speed" of the attached device 9600 - 4800 - 19,200 etc...)

    for example 9600, 8,N,1 and any error flow control parameters must be set accordingly. As I mentioned earlier some devices you attachto the serial port may only be capable of communicating at 4800 baud instead of 9600 bps. etc.. and this may bring up "denied" messages on you PC because the device can't "talk" to the serial port etc..

    Another issue with "denied access" is the fact that sometimes com ports "share" IRQ's with other devices on your PC. So when you connect an external device that "wants" to use Com 2, it gets denied access because the soundard is also using the same IRQ that Com 2 is assigned. (Usually IRQ # 1 or 3)

    So under the tab "Resources" (Again we are still in the device manager under (Ports COM & LPT) in COM 1 etc... The Resources tab enables the idea of changing or reassigning the IRQ settings. If "automatic settings" are chosen you can "deselect" the automatic settings and modify the Com port to use another or "Unused IRQ" setting or alternative IRQ arrangement.

    So for example if COM 2 is using IRQ 2 or 4 you may find those IRQ's may "also" be used by your sound card or other device in your PC.

    Also you can also use the "device manager" in the same way but can look at other devices and look at their "properties" to see if any of these other devices are also sharing the same assigned IRQ's as the COM ports are using.(I would first check the assigned IRQ's in my sound card to see if they are using the same IRQ's as my COM ports)

    So to recap, You can assign Com 1 to use IRQ 1 & 3 and Com 2 can use IRQ 2 & 4.

    So try these alternate IRQ settings and ensure the "baud" speed of the comport matches the device "baud" rate speed so there are no "data accidents" occurring from incompatible speeds in the data stream of things.

    My Best,

    Charles - KC8VWM
    Last edited by KC8VWM; 04-06-2009 at 07:24 PM.

  4. #4

    Default

    Thanks for the quick replies, I'm using Windows XP as the OS and the computer has real serial ports. I tried using the "auto detect" in the HDR software and got the same access denied message for each com port and baud rate speed. I'm going to give the ideas you both mentioned a try -- I never tried changing the baud rate for the com ports. (Also I did purchase the Icom CI-V interface but I bought it used since the price of a new one was ridiculously high.) Thanks again

  5. #5
    Join Date
    Feb 2009
    Location
    Upstate, NY
    Posts
    281

    Default

    Are you sure you have a straight wired serial cable? A null modem cable will cause what you are experiencing. Check the pinouts on the cable.

  6. #6
    Join Date
    Oct 2004
    Location
    Jacuzzi
    Posts
    11,732

    Default

    Quote Originally Posted by W4DHX View Post
    Thanks for the quick replies, I'm using Windows XP as the OS and the computer has real serial ports. I tried using the "auto detect" in the HDR software and got the same access denied message for each com port and baud rate speed. I'm going to give the ideas you both mentioned a try -- I never tried changing the baud rate for the com ports. (Also I did purchase the Icom CI-V interface but I bought it used since the price of a new one was ridiculously high.) Thanks again
    Yeah.. The problem with the "auto detect" feature is that it usually relies on an internal database to configure external devices to work on your PC.

    The device you are attaching is "strange" to the PC ,so it doesn't know how to "auto handle it." That's why you probobly need to manually configure it instead.

    My money is on the idea that the soundcard is using the same IRQ port setting as the serial comport. So the PC is saying, "No" I am already in use by the soundcard in the computer, so no you can't use me because I am already assigned to something else. (Well at least if PC's could talk english it would probobly say that


    73 de Charles - KC8VWM
    Last edited by KC8VWM; 04-06-2009 at 08:20 PM.

  7. #7

    Default

    chmod 660 /dev/ttyS0

    wait, nevermind, you are using winders so you are screwed : (

    oh and this comment

    "The problems with comports is that all devices you attach to your serial port must match in terms of the baud rate settings and flow rates or any error correction protocals as(s)signed to them"

    isn't true, baud rates etc are set by the controlling applications and not the operating system. It sounds like an application in your startup is grabbing the logical port(s) and opening it (at the OS level and not hardware). Some kind of old malware autodialer perhaps?


    73 m/4
    Last edited by AB9LZ; 04-06-2009 at 11:58 PM.

  8. #8
    Join Date
    Mar 2007
    Location
    Christchurch, New Zealand
    Posts
    737

    Default

    "Access denied" is a security thing. The software may be trying to access the physical serial port at the hardware level, rather than through the OS. Modern OSs (since 1970 or so) have always regarded direct "user" access to hardware as major security risks. Windows is starting to catch up with concepts like this.

    I haven't done much with XP; you ould try running the software as "Administrator". Otherwise., I'm pretty sure there are "drivers" around which avoid the security. A USB-serial adapter might contain this sort of thing in its driver.

  9. #9
    Join Date
    Oct 2004
    Location
    Jacuzzi
    Posts
    11,732

    Default

    Quote Originally Posted by AB9LZ View Post
    chmod 660 /dev/ttyS0

    wait, nevermind, you are using winders so you are screwed : (

    oh and this comment

    "The problems with comports is that all devices you attach to your serial port must match in terms of the baud rate settings and flow rates or any error correction protocols as(s)signed to them"

    isn't true, baud rates etc are set by the controlling applications and not the operating system. It sounds like an application in your startup is grabbing the logical port(s) and opening it (at the OS level and not hardware). Some kind of old malware autodialer perhaps?


    73 m/4
    We're not talking about Linux...

    In Windows XP, the O/S system overrides any installed software parameters and has the final say. Otherwise the installed software wouldn't be having the "denied access" issue if the software was in control.

    If the installed software says to the O/S, " Hey Windows!... I want to go at 19,200 bps on Com 1" and the comport controlled by Windows is limited to operate at a maximum speed of only 9600 bps, or if has already assigned a specific IRQ the software wants to use but Windows has decided to assign to another device ...

    Then guess what reply Windows is going come back with to the software making that request?

    ...."Error Will Robinson... Error!"

    The installed software settings don't take over and control the O/S system settings. The software can only function within the parameters specified by the operating system. It's not controlled the other way around by the installed software. (Controlling application as you put it)

    73

  10. #10

    Default

    Blackberry / PalmOS synchronization software is notorious for grabbing COM ports. You should close every addon you can, clear your tray of everything. If that doesn't do it, run msconfig and uncheck everything that makes sense - keep it from running.
    And now for something completely different...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •