WIndows7 and Echolink UDP Port Sttings

Discussion in 'Echolink/IRLP Tech Board' started by N8RT, Apr 12, 2010.

Thread Status:
Not open for further replies.
  1. N8RT

    N8RT Ham Member

    Hello all, Hopefully someone has gotten Windows 7 to work with Echolink?
    My XP computer brings up and works well with XP. No problems with the UDP or TCP Ports!
    Just got a new puter with win7, and I am trying to get Echo Link up and running.
    I found WIN7 uses an area in the Firewall advanced Security section, uses Inbound Rules and Outbound Rules, and New Rules must be set for the UDP and TCP ports!
    I have not been able to find out exactly how to use the New Rules?
    To date the My Echolink pgm (2.0.908) Current download , can connect to the Test Server properly, but will not communicate with a station!

    When using the Firewall/Router Test in Tools. I get
    TCP Succeeded
    UDP 5198 test #1 Rcvr failed
    UDP 5199 Test #1 rcvr failed
    UDP 5198 test #2 Succeeded
    uDP 5199 test #2 Rcvr Failed
    FIrewall test failed.:mad:

    I hope someone can direct me to a STEP by Step method of plugging in the NEW RULES to enable the correct UDP setup for WIN 7.:)
    Thanks rob n8rt
     
  2. VA3CSS

    VA3CSS Ham Member

    Rob, do you have a router in your home? A wireless router or a even just one that lets more than one computer access the net from your home?

    If so, simply turn OFF the firewall in Windows 7. Your router's firewall is enough.
     
  3. W0BTU

    W0BTU Ham Member

    Echolink on D-Link DI-808HV router?

    I've never been able to get Echolink working with my D-Link DI-808HV router by following the instructions, in any version of Windows or Linux. The only way Echolink works is by temporarily disabling the router's firewall, and I'm certainly not going to do that.

    Anybody have a solution? There's a group on Echolink I've been wanting to access, but I can't.
     
  4. KD7EIR

    KD7EIR Ham Member


    You went to ADVANCED then VIRTUAL SERVER? Then set the private IP to the IP of the machine that you are running EchoLink on? Then set the protocol to UDP, and set the private port and public port to the same thing? Set Schedule to Always?

    That worked perfectly for me.
     
  5. KD7EIR

    KD7EIR Ham Member


    In Windows 7, delete any rules that you made in the firewall. Then launch EchoLink. You should be prompted to create an exception. Create the exception, and EchoLink should work just fine.
     
  6. N8RT

    N8RT Ham Member

    Thank You ALL for the info. A few others posted info that WIN 7 works just fine with Echolink, without using UDP or 5200 in the Firewall NEW Rules. SO I deleted all the NEW rules UDP and TCP edits.

    In Windows accessories COMMAND Prompt, I Typed in IPCONFIG, and found my computer IP Address, Next I checked my Linksys Router to make sure it was POrt forwarding to my correct IP address. It was not , so I edited the Port Forwarding for both UDP 5198 and 5199 and TCP 5200 , and ECHOLINK, FIREWALL Passed !
    I am now running ECHOLINK on WIndows 7 just fine.
    73 Rob N8RT
     
  7. K7MYR

    K7MYR Ham Member

    Howdy,



    Yeah, I just installed Echolink on Winblows 7and it immediately asked for the "exception" which I approved. (WIN7 Ultimate 64bit)

    My Linksys router is another situation though.

    The instructions to allow the UDP ports are easy enough. The main problem most will probably have is that you MUST set up your router clients with an assigned IP address.

    You cannot use DHCP on your router and the computer you want to use with Echolink unless you reconfigure the port forwarding every time you reboot your computer and/or the router assigns a new IP address! You then would have to set up the routers port forwarding every time.


    The "fix" is to use a fixed IP address on the computer you want to use for Echolink and configure port forwarding in the router for that address......
     
  8. K6NVG

    K6NVG Ham Member

    I used the website www.portforward.com.

    They have instructions for setting up Echolink on many different routers. Echolink is one of the programs in the list.
     
  9. VA3CSS

    VA3CSS Ham Member

    No, the "fix" is increasing your Lease Time for the IP address to something more than one hour. This is done in your router as well.

    Or... see if your router has a firmware update that allows you to connect an IP address to your MAC address, making lease times irrelevant.
     
  10. K7MYR

    K7MYR Ham Member

    But that lease time is more for the Router address to the ISP and not the LAN client addresses is it?

    At any given time I probably have 5 or more active connections on my LAN ........ 192.168.1.100, 101, 102, 103 etc.

    I know I can switch everyone to fixed addresses .....

    But everyone is using a laptop or netbook, iPhone etc and doesn't want to have to switch back and forth from fixed to DHCP....

    What am I missing here?
     
  11. AB8ZL

    AB8ZL Ham Member

    Increasing the lease time isn’t the answer; you need to use a static address for the Echolink computer.

    You can setup the computer you use for Echolink to have a static address and still allow all the other computers to use DHCP. Some routers will assign a static address by MAC address, but if yours doesn’t you can set it up on the computer itself. Just pick an unused IP address outside of the range issued by the DHCP service of the router. Usually 192.168.1.2 or 192.168.1.254 are safe but you should be able to find where the routers DHCP range is set in its setup screens.

    Google for “setting up a static IP” for your specific OS.

    You will need to enter the IP address you want for the computer, a Subnet mask (255.255.255.0 for almost all home routers), the Default Gateway (the address of your router, 192.168.1.1 for most home routers), and your DNS servers. You can get the DNS servers by running “ipconfig /all” at a command prompt or use a set of public DNS servers (Googles are 8.8.8.8 and 8.8.4.4 and OpneDNS’s are 208.67.222.220 and 208.67.222.222).
     
  12. K7MYR

    K7MYR Ham Member

    Ok,

    I understand I need to use a static address on my laptop at home but will I need to reconfigure it for DHCP each time when I go on the road if I want to use Echolink on another network?
     
  13. AB8ZL

    AB8ZL Ham Member

    Well yes if you have to set it up on the computer you would have to switch back to DHCP to use the computer on other networks.

    It is best to setup static addresses on the router if the router allows for assigning static addresses by MAC address. Using Echolink on other networks usually isn’t an option as you don’t normally have access to the firewall port forwarding rules.

    Some routers allow you to setup port triggering; if yours has that option you may get Echolink to work with it which would allow you to use a dynamically assigned address with the router.
     
  14. K7MYR

    K7MYR Ham Member

    Thanks, I might look into that.

    It's a Linksys router. (My first router was an old AMD K6 computer running a "linux-router-on-a-floppy") It worked well but I never tried to set any sort of port forwarding.
     
  15. VA3CSS

    VA3CSS Ham Member

    Not at all.

    All DHCP servers have a lease time for IP addresses. What IP your ISP gives you is irrellevent. It does not affect your firewall settings for Echolink. Therefore, your router's lease time settings are the only ones that matter in this case.

    And as you already noted, a static IP address will only work if the computer never connects by any other means.
     
  16. K7MYR

    K7MYR Ham Member


    Yes, that's what I thought.

    I did not know that I could control the lease time the router assigns to each client on a LAN. If it gave each client a LONG lease time, it would effectively be giving each client a fixed IP address then? SO that if one client was disconnected for a time (less than the lease time) and reconnected it would get the same IP address back?
     
  17. VA3CSS

    VA3CSS Ham Member

    Exactly.

    So long as that's an option in your particular router. Most recent models do support this. Some older ones do not, or may need a firmware update to add this.
     
  18. W4PG

    W4PG Moderator Staff Member

    Are there any routers that how outbound protection? I have Zone Alarm on all my XP machines, but Windows 7 firewall has outbound protection that previous versions did not have. The last thing anyone wants is some Trojan sending out personal data from your computer to another.

    ..........Bob
     
  19. VA3CSS

    VA3CSS Ham Member

    In a manner of speaking, yes, some do.

    Some routers can block ALL traffic on a given port, so that would include outbound. The problem is... what port is that trojan you have using?? You'd have to know it.

    I suppose you can do what many do, which is to block all traffic on all ports, and open up only the ones you need for the programs you use. A cumbersome, and annoying method, but it does work - even if you don't know which port the trojan you just got is using.

    It also assumes that the trojan isn't capable of simply using any open port that it can find. There has to be one, since that's how you get the trojan to begin with. If it can "seek out" an open port to use, then the above method is rendered null and void.

    And yes, some trojans can do just that. We don't live in a perfect world, unfortunately.



    Also remember that it is assumed, (and I know, that's not a good word to use...) that the user of the computer is aware of the programs he / she is using that require access to the net. Hence, most routers don't use the "block everything except..." method I suggested above, just to prevent the angry calls to their tech support saying that they're switching to a different brand so that such-and-such program will work. They assume you'll know what you have.

    ZoneAlarm is, therefore, a handy tool when you're unsure, or suspect that something is up. If you're not that adept at computers, then programs like ZoneAlarm help to "cover your ass," as it were. ;)
     
  20. K7MYR

    K7MYR Ham Member


    Thanks!


    Actually I did find a screen on the Linksys that allows a variable lease time (default 1 day) for DHCP assigned addresses.
     
Thread Status:
Not open for further replies.

Share This Page

ad: Momobeam-1