Windows 7 64bit USB to Serial

Discussion in 'Computers, Hardware, and Operating Systems' started by KC9FSH, Dec 20, 2009.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: L-rfparts
ad: l-innov
ad: l-rl
ad: l-gcopper
ad: l-Waters
  1. KC9FSH

    KC9FSH Ham Member QRZ Page

    I am running Windows 7 64 bit Ultimate edition and tried to use my USB to Serial converters that I've used for the past few years to control my radio.

    I downloaded the latest Prolific drivers and installed them yet the USB to Serial converters still come up that Windows Failed to Install Device or something along those lines.
    When I go into device manager the converter does appear in the list but it has a yellow exclamation mark next to it, in the device properties the error message is

    "This device is not configured correctly. (Code 1)

    The name is already in use as either a service name or a service display name."

    Everything I've tried still hasn't helped. Does anyone have any ideas on what could be causing this? If I can't get it working then what does everyone else use for usb to serial adapters?
  2. WD0MYM

    WD0MYM Premium Subscriber QRZ Page

    I can't help you with the problem your having with your current adapter. I'm not smart enough!! I have tried 2 different adapters. The first one is from Keyspan model USA 19HS. It works perfectly. That was my backup adapter I used with the YAESU CT62 cable. Notice the caps in Yaesu. I have seen some cables possibly being sold as a Yaesu brand cable. The Keyspan adapter is fairly popular, I read about folks having good luck with it.

    The other cable in use daily is the one sold by RT Systems. I don't know if they make a model for every radio, but it eliminates purchasing the adapter, as it already has the USB end on it. It is priced right. As of right now, it is the cable I prefer for my setup. I have a very small issue with the RT: the USB end is pretty wide, which means I have to plug it into the end of the computer that has one USB port on it. I can't plug it into the other side where I have 2 USB ports right next to eachother. I can plug it in, but it will block the other opening for the USB port because of its size.

    My equipment is as follows: Brand new HP laptop with Windows 7 64 bit and a Yaesu 857D. I am using HRD and DM780 Version 5. I also use the Signalink USB along with the cat cable from RT systems. I connect at the highest speed available, 38,400 and run the refresh rate at a 100 miliseconds which is the fastest that is available in HRD.

    I hope this helps. Both cables work flawlessly and I am sure other adapters will work well.

    73 Jon
    Last edited: Dec 20, 2009
  3. VA3CSS

    VA3CSS Ham Member QRZ Page

    Double-check that you got the correct one. I have a Prolific-manufactured USB to Serial adapter working just fine in Vista 64-bit, which uses the same driver as Windows 7 64-bit.
  4. YU2MMA

    YU2MMA Ham Member QRZ Page

    You can isntall virtual machine and install Wndows XP on it. Than you can try like this to connect your rig. Friend of mine use Ham Radio Deluxe, and his server is on virual machie, and he is using remote connection on installed HRD on Win 7 to Win XP
  5. N2RJ

    N2RJ Ham Member QRZ Page

    I have a PL2302 USB to serial working as well as a keyspan USB to serial working. This is in Win 7 x64 home premium.

    Which adapter do you have?

    The VM thing is overkill, IMO. YOu shouldn't have to fire up a vm every time you want to play radio... might as well just downgrade back to XP!
  6. KD0DKI

    KD0DKI Ham Member QRZ Page

    If the processor supports virtualization.
    XP mode is not virtual . PC.

    BTW W7Pro is installing on my new rig, asus M4A78T-E, 6 Gig of DDR3, AMD Phenom II X3 705e at 2.5ghz. Santa was very good to me this year!

    Lots of configuration of W7Pro to do to get it to work as I want it but it shouldn't be to bad.
  7. KC9FSH

    KC9FSH Ham Member QRZ Page

    I tried the Vista drivers along with the ones that Prolific said were for Windows 7. I believe the issue is a conflict with something on my computer, but I can't figure it out.

    I'm normally pretty good at troubleshooting what is wrong with the computer, but I think I'll have to break down and bring it over to one of my buddie's and have him look at it.
  8. KA7O

    KA7O Ham Member QRZ Page

    Connect all USB to serial adapters you've ever installed.

    In Device Manager - DELETE them all (have to connect them first so they show up! Easy to find the borked ones with the yellow warning. Delete all of them anyway.)

    Shut down the PC (power off - No sleep, hibernate or 'stand-by' - must be a real power off "cold stop". May have to modify your start button properties to get this)

    Disconnect all USB to serial adapters

    Turn PC back on

    Re-install drivers

    Re-connect adapters

    good luck!
  9. KC9FSH

    KC9FSH Ham Member QRZ Page

    I just tried that and I'm still getting the following error when I view the USB to Serial in device manager.

    "This device is not configured correctly. (Code 1)

    The name is already in use as either a service name or a service display name."

    The motherboard I'm running is a Asus M3A78-EM.
  10. N2RJ

    N2RJ Ham Member QRZ Page

    I had this same problem. I recently got a new HP e9280t (Core i7) with Win 7 x64, connected my USB to serial adapter and it didn't work.

    I then downloaded the driver from here.

    This driver works well with Win 7. Just make sure your adapter is disconnected when you do the install. If it fails on one USB port, try another port and it will pick up the driver. You can then switch back and it will work.

    Let me know how it works out.
  11. WA4LZC

    WA4LZC Platinum Subscriber QRZ Page

    I use the Prolific Adapter to connect my weather station to my computer and had the same problem. When I converted to 7 I just loaded it over XP and that is what I think caused my problem, a conflict between XP drivers and Window 7 drivers.:( The way I got my adapters to work was to do a format and clean reload of Windows 7 Ultimate 64 bit and it has been working perfectly ever since.:D:D:D
  12. KC9FSH

    KC9FSH Ham Member QRZ Page

    I just uninstalled whatever driver was installed, rebooted and then tried installing that driver. It still has the same issue. My motherboard does have a set of header pins for a serial port, so I found a connector that will work with it, so at least I have my digital interface working. I'm seriously considering rebuilding my CI-V interface and make it so that my digital interface can still key off of the same serial port as the CI-V interface, however I'm debating on this right now.

    This was a fresh install on a new computer, so the having a conflict like this is unlikely. I have a feeling that it is a conflict with some hardware setting on my computer. If worst comes to worst I may try reinstalling my copy of Windows 7.
  13. KB3SDS

    KB3SDS Ham Member QRZ Page

    Try the vista driver, that's the one that worked for me.
  14. KC9FSH

    KC9FSH Ham Member QRZ Page

    I already tried that one as well.

    This past weekend I really confirmed that something isn't quite right with this computer and serial ports. I was using my serial port connection that connects to the motherboard via a set of header pins. It works great for keying up the radio for digital modes but it won't work for rig control with my IC-756ProII or IC-706mkiig.

    Looks like I may try a reinstall of Windows 7 and see if that may fix my issues.
  15. AC0IV

    AC0IV Premium Subscriber QRZ Page

    USB to Serial

    I had many issues with the USB to serial in Windows 7 64 bit to radio. I talked to the radio rep and he stated that there are problems with the standard and that is why they do not put usb ports on their radio. With that information I decided to put in a PCI express to serial port. Cost about $35. Now my radios and antenna controllers work 100% 100% of the time. I have purchased many USB to serial and find that the best solution is the serial port card. By the way I realy like Win 7 64 bit.:D

    73 and good luck.
  16. K7CJ

    K7CJ Ham Member QRZ Page

    KC9FSH -

    First off, make sure you have the Prolific USB adapter. You can check this by going into Device Manager and right-clicking the device and choosing properties.

    Click on the details tab. Under property, select Hardware ID.

    You should see something like this:


    The VID_067B is the Vendor ID for Prolific. The PID_2303 is the product ID for the cable. If you don't see this value, then you're using a different product.

    The latest drivers only work with the 2303 model of converter cable. Latest drivers for Win7 X64 here:

    For your on-board serial port problem:

    Check your system BIOS. Make sure the COM ports are NOT set to "Auto" - it should be COM1/COM2.

  17. N4REV

    N4REV Ham Member QRZ Page

    One more thing to try:

    Turn off the serial port(s) on your motherboard via the BIOS set-up. Disable them.

    Then re-try the USB-to-Serial Doohickey.
  18. KC9FSH

    KC9FSH Ham Member QRZ Page

    I just confirmed that it is a Prolific adapter.
  19. WB1HJS

    WB1HJS Ham Member QRZ Page

    I just migrated to a new system this weekend running Win 7 Ultimate 64bit, and am having the same problem. I tried just about everything I could find here and in a general Google search on the subject. The best I can do is get it working on COM3 at 4800 Baud with my 897D and HRD for a short period of time before it barfs.

    I ordered a dual serial port PCI card and some 9 pin Dsubs and am going to chop the cable and wire it as a serial cable.
  20. K7CJ

    K7CJ Ham Member QRZ Page

    Are you using the Prolific adapter or on-board serial ports? If you're using the Prolific adapter, make sure you have the latest x64 driver update. Also, you may have to tweak the serial port settings specifically (such as DTR, DTS, etc.)
Thread Status:
Not open for further replies.

Share This Page

ad: ELADIT-1