ad: dxeng

Vx-170 Programming cable, Windows gives error 10.

Discussion in 'Mobile Radio Systems' started by KJ6OJL, Jan 6, 2012.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-assoc
ad: l-rl
ad: L-rfparts
ad: l-innov
ad: l-gcopper
ad: l-Waters
  1. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Ok, Well tried to run the programming cable for my vx-170.
    I got a error code of 10 From windows.
    No I did not have the money to buy a big brand cable instead I bought this one
    Their download link is dead.
    When I searched for a alternate driver I discovered this one
    Tried it HOPING, It would be a go. Nope It gets the error 10
    that they talk about.
    anyone have any ideas Or other drivers to try?.
    I have even tried uninstalling, installing and setting a new com port.
    A no go either way same error!..

  2. KK4FUS

    KK4FUS Ham Member QRZ Page

    There was a discussion about RS232 converters recently. Apparently some cheap cables are using fake Prolific chips.

    For what it's worth, I'm using a cable that looks 100% identical to the one in your link, bought from another seller in Taiwan. Don't know whether it's fake or real, but it works flawlessly for me (Win7 x64 SP1).

    Here is the driver I'm using, maybe it will help you:

    Attached Files:

  3. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Thanks I will try this driver in next few hours and report back.
    mine came from
    Yu zhping
    Room 1120, Gelinwangyuan
    Building, zhenxing road futian
    Shenzhen Guangdong china 518028

  4. KK4FUS

    KK4FUS Ham Member QRZ Page

    I didn't keep the envelope mine came in. I bought it from the seller "kawacool", that's all I know. And I was wrong, the seller is from Hong Kong, not Taiwan.

    Good luck with the drivers, hope you will get your cable working.
  5. W9GB

    W9GB Ham Member QRZ Page

    The Prolific web page you listed has the latest drivers (past few months) for the Prolific chip set.

    The Yaesu VX-170 has a serial TTL interface for programming. This is normally a serial port off the VX-170 uProcessor.
    In order to interface this Transistor-transistor Logic (TTL) has to be converted to the
    RS-232 (1970s comm standard) or Universal Serial Bus (USB) interfaces found on personal computers ---–transistor_logic

    LEVEL CONVERTERS are required. Prolific (Taiwan/China) sells USB to TTL intergated circuits that perfrom this conversion --
    and are powered (DC) either externally or from the USB hardware connector. RS-232 (commonly seen as DE-9 connector) is another different standard.

    The drivers provided by Dan, KK4FUS are an earlier verison of Prolific drivers, for devices using PL-2303H/HX/X version chip.

    PL2303 Driver Installer v1.3.0
    Driver Versions:
    - Windows 98/ME Driver: v2.0.0.19
    - Windows 2000/XP/Server2003 (32 & 64-bit) WDM WHQL Driver: v2.0.13.130
    - Windows Vista/7/Server2008 (32 & 64-bit) WDF WHQL Driver: v3.3.11.152

    FIRST, you need to "clean out" the earlier drivers that produced the Error Code 10.
    Prolific has a couple of utilities for this, on the web link you already have.
    They specifcally advise using, stating that the Windows Control Panel removal is "not always complete".

    The Microsoft -- Error Code 10 -- is a device driver error. I ASSUME you are running MS Windows XP ???

    Step through these potential issues that can cause the Error Code 10 condition.
    Microsoft Knowledge Article ID: 943104 - Last Review: November 23, 2011 - Revision: 5.0
    Description of Code 10-related errors that Device Manager generates in Windows-based computers

    Last edited: Jan 6, 2012
  6. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    As of now, It seems to have installed once I found a file it said was missing.
    It acted like it was working, but when I put the radio into "CLONE" to pull the existing
    data, It says -----Tx------
    then goes to error after about 2 seconds.
    I will try the latest suggestion and see if that changes anything.
    Seems close.. but will see..
    No idea what chip is supposed to be in this cable.
    But have read and discovered after the fact of buying that there has been so many
    knock off's going, which this one claims no branding, but also still not going.
  7. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    So, there is another piece of hardware needed as well?.
    Hurm, well interesting. I thought the one cable had what was needed built in.
    will try everything in a bit here. Kinda doing this in-between everything else going on

  8. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    ok, Seems like driver is working, I get program to confirm radio on and radio off 00 returned.
    but then when it comes to "clone" I hit TX where I am supposed to radio returns a "ERROR" and
    Im a little lost now.
    Might check out a few other programs.
  9. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    OK, I get the same error from having connector or no connector hooked up.
    Starting to wonder possible radio issue?
  10. KK4FUS

    KK4FUS Ham Member QRZ Page

    (sigh) Just opened my programming cable. The chip inside is labeled PL-2303HXC. There is also a level translator made with 4 transistors and a few resistors. It is not a RadioShack USB to RS232 cable, it's a cable made specifically for Yaesu radios. No additional converters or adapters are required. One end of the cable plugs into the computer, the other end plugs into the radio.
  11. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Ok, So it sounds the same as what I have, dedicated cable.
    I dont see a way to open this unit and verify chip on it though.
    windows see's it and comport, even get 00 when running test in the FTB2070 software.
    Oddly the software says should report back 50...
    Cant find anything to confirm or deny that there is another issue.
    but the radio saying error same way with or without cable is interesting

  12. KK4FUS

    KK4FUS Ham Member QRZ Page

    Here is how you can make sure the drivers are installed and working. Open a terminal program and select the COM port that's assigned to your programming cable. Turn the local echo ON. Now type anything, and you should see the characters doubling up (if you type "ABCDE", you will see "AABBCCDDEE" on the screen). The first character in the pair is local echo, the second one comes through the programming cable (Tx and Rx signals are tied together in the level translator inside the cable).
  13. KK4FUS

    KK4FUS Ham Member QRZ Page


  14. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Just confirmed, Yes getting the local echo.
    Now making me wonder about this radio.
    Will flip through the manual. Something still amiss.
  15. KJ6OJL

    KJ6OJL Subscriber QRZ Page

  16. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Still trouble shooting

    Well still trouble shooting.
    Searched for more possible causes. Looks like possibly low voltage issue.
    Have not been able to find out what max charged and minimal charge voltage is on this radio.
    If it's in the manual I have missed it so far. As of now showing about 7.5 volts.
    If I remember correctly it's was 8.5 on full charge. When charger removed after 16 hours or so.
    From everything I have read and followed I don't think there is anything I'm missing steps wise.
    As of now cable or no cable when in clone and hit tx to send data to program I get error after 2 seconds.
    Still wonder what min voltage is and max. Anyone got a idea?

    Last edited: Jan 6, 2012
  17. KK4FUS

    KK4FUS Ham Member QRZ Page

    I would say 7.5V is normal for a charged 6-cell NiMH battery under light load. I don't think you have a problem there.

    You are doing everything in order, right? For my VX-3R, the sequence is:
    - Click the "Read Radio" button, a window pops up that says "You are about to read the radio";
    - Put the radio in the clone mode;
    - Click "OK";
    - Press the button on the radio that starts the cloning.
  18. KK4FUS

    KK4FUS Ham Member QRZ Page

    Not much damage, the case cracks open pretty clean. A drop of glue will make it whole again (that is, when I get around to it).
  19. AJ4VA

    AJ4VA Ham Member QRZ Page

    You have probably already checked, but is the cable plug getting fully seated into the radio?

    Just a thought.

  20. KJ6OJL

    KJ6OJL Subscriber QRZ Page

    Yea, followed directions on the software, power on choose com port, then tell it read radio, 1st screen pops up telling you how to put radio into "clone" then hit ok for next screen, next screen is push TX until radio starts to send data and program sits listening for it.
    Followed to the letter.

    As for cable seating into the connector, It does appear to be connected and tightened all the way down, The one thing I wonder is there is TWO o rings which I wonder if one of them is making it feel as it is all the way in but could be a little out.
    The way they made this connector its virtually impossible to visually verify its seated 100% in and screwed down.
    So I am pretty sure its in all the way, but with the oring (dust / moisture protection) I was getting return from the software of activity on com port and 00 when radio was turned off and back on..

    Am at a friends house right now on their mac, finding software which will work on a mac is becoming a bigger challenge than expected today lol.
    Wont be at home in front of my pc for hours.
Thread Status:
Not open for further replies.

Share This Page