TS-930 has no display, no function in general

Discussion in 'Radio Circuits, Repair & Performance' started by DL4UNY, Feb 10, 2013.

Thread Status:
Not open for further replies.
ad: L-HROutlet
ad: l-rl
ad: L-MFJ
ad: Subscribe
ad: l-assoc
  1. DL4UNY

    DL4UNY Ham Member QRZ Page

    Hi all,
    I'm about the repair my lovely TS-930S without great success. I repaired the power supply, I reflowed all the 'vias' on the digital unit. The Voltages from the PSU-unit are quite okay, but not at the digital unit. After a week of looking for the broken part I ran out of ideas and want to ask you out there. I saw some great posts here about the TS-930 but nothing with my problems / sympthoms.
    I can not do anything, means I can not switch TX/RX, I can not hear noise out of the speaker but a long beeep, I have no display, I can not hear the band switching when pushing the buttons, I can not see signals when tuning the dial knob.
    To show you what I already did and measured I uploaded some information http://dl4uny.de/ts930.html here. I hope that someone here had similar problems and knows how to solve them...

    Measurement devices: scope, multi meter, spectr. analyzer.

    Thanks in advance,
    73
    Andre, DL4UNY
     
    Last edited: Feb 10, 2013
  2. KE3WD

    KE3WD Ham Member QRZ Page

    Double check the polarity where you found that Tantalum cap in "backwards" -- the typical failure mode for a Tantalum cap that is connected to DC backwards is a sudden short followed by the Tantalum cap blowing like a firecracker. The fact that the radio worked all that time beforehand would indicate that the cap was NOT connected backwards.

    I'm thinking that "backwards" cap was found on the 4.7V supply because your table now reads zero volts there.

    I'm also thinking that ALL of your problems have to do with the power supply and not the other boards such as the digital boards.

    When the PS looks like the one in your picture, with all those heat marks, it must be rebuilt.

    You should also check from the Power Transformer for proper AC voltages, as well as check all rectifiers to make sure there are none shorted or open.

    You have the -47V (-50V reading may not indicate anything really wrong here) in some places but not in others. That could indicate a blown series resistor going to the circuits where you measured zero.

    And make sure that Return paths such as might happen through board hold down screws, are good.


    73
     
  3. DL4UNY

    DL4UNY Ham Member QRZ Page

    thanks for the answer. I also discovered that the 7808 was blown again. I exchanged it and it blew up again.
    About the tantalum cap: it was not blown because it was never used. Check this: http://dl4uny.de/image/ts930_vreg.jpg
    The output pin is empty. It was stil working via the 7V8-Zener behind the heat sink.
    What could make a voltage regulator such like the 7808 blow up? There is no short between the 8V-path and ground...

    Would you suggest to use a new power supply such like http://brisdance.com/vk4amz/ts930.html rather than make a redesign of the entire power supply like it is now?
    The voltages out of the PSU are okay, I read 28V and 22.7V. So I don't know what I could check again...

    Edit: I measured the AC voltages from the transformer: the inner contacts (going to connector 5 on the PSU) have 17V and whats going directly to the rectifiers on the heat sink has 31.8V.
    But I don't have any reference to compare if those voltages are okay.

    73
    Andre
     
    Last edited: Feb 10, 2013
  4. KE3WD

    KE3WD Ham Member QRZ Page

    What is the DC voltage being fed IN to that 7808? Any voltage above 8VDC gets turned into heat. But the 7808 is temperature protected. If it gets too hot, it will stop outputting voltage, but allowing it to cool should restore the voltage.

    Is that 7808 properly mounted to a heatsink?

    There could be something shorted out in one of the circuits that it powers that could be drawing down the voltage as well as overheating the '808. Try disconnecting that line from the various boards it goes to one at a time and then observe the 7808 heating and dc output to see if it stays on with one of the boards disconnected. If so, time to troubleshoot for the fault on that particular board.


    73
     
  5. DL4UNY

    DL4UNY Ham Member QRZ Page

    The 7808 is mounted on the heat sink, yes. The input voltage is 22V from the PSU. Do you know what current should flow into the circuit (The 7808 goes directly to the digital unit and there it goes directly to an 7805)? I measure 1.6A by a lab-supply. I don't know if this is correct or too much. If it is correct, what I don't believe, then it's no wonder why the 7808 was blown twice...
    Do you know if the output voltages of the transformer are correct?

    73
    Andre
     
  6. KE3WD

    KE3WD Ham Member QRZ Page

    The AC voltage to the three regulators is specified as "21.7" so your measurement of 22 is correct.

    A quick Websearch brings up this page on the '930, note the comments concerning the power supply near the bottom.

    http://www.kb2ljj.com/data/kenwood/ts-930.htm#1638

    It is common to use three-terminal regulators in steps, as you have observed with the scheme of first regulating down to 8V and then regulating with a 5V three-terminal onboard the digital board.

    The 78-- series of three terminal regulators are typically 1A max, although you might find some newer examples that are higher, this radio was designed a long time before that, so I doubt that's an issue.

    However, if all three are drawing that 1.6A cited, don't know. How did you measure that, with an AC Ammeter?

    A three-terminal regulator inadvertently installed wrong might blow every time, recheck that carefully as to the pins and their connections.

    Did you recheck those ones that you think are blown after letting them cool down? There is still the possibility that they did not blow but their overheat protection shut them down. I mentioned that earlier. You should check that, as it would be a big clue as to what's really going on.


    73
     
  7. DL4UNY

    DL4UNY Ham Member QRZ Page

    Okay, I measured everything in single steps, as you suggested. I connected connector 1 of the digital unit only and measured current and voltage. I connected two new 78xx to an external heat sink to have a better control (will upload the picture this evening and post the link).With nothing but the 8V and 15V connected I measure:
    8V 1.5A
    15V 0.45A
    Going closer to the digital unit I measure 12.2V at the output of the 7812 and 0V on the 7805 output. I unsoldered it and measured again: there is an short in the 5V-lane. Now I need to find where... :)
    Now I measured with an DC-meter. Before that I trusted the display of the power supply on my desk...

    I also checked the 7808 today, after 24hrs of 'cooling down'. Yes, they are definitely defect. One gives some 2V and the other 0.xV.

    tnx

    Andre, DL4UNY
     
  8. W9GB

    W9GB Ham Member QRZ Page

    In the early 1990s, I discovered some "no-name" 3-pin voltage regulators (78xx) were actually mfg. backwards (IN, OUT terminals flipped) from the US/North American mfg. convention.
    CHECKING your new parts against Kenwood TS-930S board alignments -- is a very good idea.
     
  9. KE3WD

    KE3WD Ham Member QRZ Page

    Sometimes the failure mode of the 7805 can be zero or close to it when asked to power circuits, disconnecting the output can show the proper 5V but the regulator may still be bad, can't handle current.

    If you have an external regulated 5V supply, try powering the 5V board from it. Or try just replacing the 7805 and see what happens.

    Also suspect a leaky electrolytic cap immediately following the 7805.

    I suspect a problem here, the 7808 is a 1A max device. Something it is powering is drawing more current than it should.

    Could be just the 7805 under load.

    73
     
  10. DL4UNY

    DL4UNY Ham Member QRZ Page

    Thanks for the advice, I did that. The regulators are made by NEC Japan and the pin out is like we are used to. I found a problem:
    The IC29 on the digital board, an 7475, shorted directly to ground. Don't know why, I never saw this before and I don't know what could have caused this defect. I will replace it when I'm back at home and see if this was all the trouble.

    I will replace the old 7805 by a new one. Earlier I exchanged all electrolytic caps by new ones. The old one leaked out, almost all of them.

    73
    Andre
     
Thread Status:
Not open for further replies.

Share This Page