ad: Schulman-1

Ts-50 (intermittent) Low Audio all bands (LSB, USB) but not FM

Discussion in 'Radio Circuits, Repair & Performance' started by VE3GVW, Aug 3, 2019.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: L-MFJ
ad: Subscribe
ad: Left-3
ad: Left-2
  1. VE3GVW

    VE3GVW Ham Member QRZ Page

    Hello,
    My Ts-50 has Low audio 1/2 volume (and distortion) is present 99 % of the time. Tx audio is reported as

    "sounds like RF in audio". This problem on all Bands USB and LSB. FM is not affected. (normal volume )

    I have not talked to anyone on FM. ( so no signal reports)

    Occasionally the audio randomly goes back to normal but if i lightly tap the top of the case (1 finger)

    the fault returns.

    Doug VE3GVW
     
  2. KA5IPF

    KA5IPF Ham Member QRZ Page

    Most likely it's the DDS resistor packs in the PLL unit. They need the solder joints reflowed. Do you have a 'scope? Fairly common problem.
     
  3. VE3GVW

    VE3GVW Ham Member QRZ Page

    Hi Cliff,
    Im having trouble identifying the PLL board and the location of the dds resistor packs.

    I don't want to touch the board unless i'm 100 % sure.

    I think the PLL board is on the bottom front of the unit.

    On board that can be removed there are 2 shields , each soldered in the 4 corners

    are the DDS resistor packs in there ?

    thanks
    Doug VE3GVW
     
  4. KA5IPF

    KA5IPF Ham Member QRZ Page

    The PLL is under the digital unit on the bottom of the radio. Remove the digital unit. Be very careful not to damage the ribbon cable connectors. Remove the PLL unit and then unsolder the covers.

    Remove the shields and reflow the resistor packs. They are SM and look like 16 pin IC's.
     

Share This Page