ad: hrd-2

Ten Tec 422 b is blowing fuses, help!

Discussion in 'Amateur Radio Amplifiers' started by KB4MNG, Nov 14, 2017 at 1:22 AM.

ad: L-HROutlet
ad: l-rl
ad: L-rfparts
ad: Subscribe
  1. KB4MNG

    KB4MNG Ham Member QRZ Page

    My friend has a 422b, black face - manufactured in 2006. He was operating a net for around an hour. He heard what he described as the positive and negative on a car battery terminals coming together. The amp went dead.
    Some details...

    Runs on 220v
    Everything was fine prior to the "pop"
    The fuse blown is on the black line, the holder that is close to the side of the unit. The other side does not blow.
    When you install the new fuse, it immediately blows.
    He was instructed by some one experienced to do resistance checks on the transformer and the checks show ok.

    So what do you experts think?
     
  2. W1QJ

    W1QJ Ham Member QRZ Page

    1. Remove both tubes, install a new fuse. Turn on. Does fuse blow? No? Bad tube(s) Replace tube(s) Fuse blows yes? See #2
    2. Check rectifier diodes with diode check on VOM. Replace bad ones. No bad ones? Check filter caps. Can't tell? See #3
    3. Isolate transformer secondary from rectifier. Turn amp on. Fuse blows? No? Replace filter caps. Fuse blows. yes? see#4
    4. Possible shorted transformer or associated wiring, soft start etc.
     
  3. KB4MNG

    KB4MNG Ham Member QRZ Page

    thanks for the information. I will forward to my friend and give you an update when completed.
     
  4. W1QJ

    W1QJ Ham Member QRZ Page

    Yes, please do
     

Share This Page