ad: wmr-1

Serial Port - Access Denied

Discussion in 'General Technical Questions and Answers' started by W4DHX, Apr 6, 2009.

Thread Status:
Not open for further replies.
  1. W4DHX

    W4DHX Premium Subscriber QRZ Page

    I have an Icom 718 and planned to use the CI-V (CT-17) level converter to control the transceiver from the computer. Problem is the computer will not let me access the serial ports (COM1 or COM 2). I keep getting an “access denied” message when I try to connect to it through Ham Radio Deluxe. I removed every fax, mobile phone or PDA program I could find on the hard drive thinking one of these programs was holding the ports open. I even purchased a serial to USB cable which created a COM 3 port and access was still denied. I’m out of ideas, anybody else have this issue?
     
  2. AB8ZL

    AB8ZL Ham Member QRZ Page

    You haven’t given much information to go on.

    Does your computer have real serial ports, or do you only have USB ports?

    What is your operating system?

    Is your C-17 the Icom C-17 level converter or are you using an aftermarket one?
    Hopefully you didn’t pay the ridiculous price that Icom wants for the C-17, there is a number of aftermarket ones that work fine for about $13.00 shipped to your door available on eBay (I use this one).

    Have you tried the ‘Auto Detect’ for Com port and Speed listed in the dropdown boxes in the Connect window of HRD?

    If it’s a USB interface, then it may be assigned a COM port above 4, check in the ‘Control Panel > System > Device Manager’ to see what Com ports you have available both before and after plugging in the USB cable. The one that appears after plugging in the cable is the Com port you want to use. HRD will recognize Com ports up to 256.
     
  3. KC8VWM

    KC8VWM Ham Member QRZ Page

    In the device manager you can change the settings of the comport.

    The problems with comports is that all devices you attach to your serial port must match in terms of the baud rate settings and flow rates or any error correction protocals assigned to them.

    From the control panel go to "system" and then in System find the "device manager" on your PC.

    In the device manager you will be provided a list of devices.

    look for (Ports COM & LPT) and expand it. Choose "Communications Port (COM1)" or (COM 2 etc... and click on it.

    This will bring up some tabs. Select the tab called "Port Settings"

    As I mentioned earlier these "settings" must be configured equally to the device that is attached to the serial port. (You need to know the "communication speed" of the attached device 9600 - 4800 - 19,200 etc...)

    for example 9600, 8,N,1 and any error flow control parameters must be set accordingly. As I mentioned earlier some devices you attachto the serial port may only be capable of communicating at 4800 baud instead of 9600 bps. etc.. and this may bring up "denied" messages on you PC because the device can't "talk" to the serial port etc..

    Another issue with "denied access" is the fact that sometimes com ports "share" IRQ's with other devices on your PC. So when you connect an external device that "wants" to use Com 2, it gets denied access because the soundard is also using the same IRQ that Com 2 is assigned. (Usually IRQ # 1 or 3)

    So under the tab "Resources" (Again we are still in the device manager under (Ports COM & LPT) in COM 1 etc... The Resources tab enables the idea of changing or reassigning the IRQ settings. If "automatic settings" are chosen you can "deselect" the automatic settings and modify the Com port to use another or "Unused IRQ" setting or alternative IRQ arrangement.

    So for example if COM 2 is using IRQ 2 or 4 you may find those IRQ's may "also" be used by your sound card or other device in your PC.

    Also you can also use the "device manager" in the same way but can look at other devices and look at their "properties" to see if any of these other devices are also sharing the same assigned IRQ's as the COM ports are using.(I would first check the assigned IRQ's in my sound card to see if they are using the same IRQ's as my COM ports)

    So to recap, You can assign Com 1 to use IRQ 1 & 3 and Com 2 can use IRQ 2 & 4.

    So try these alternate IRQ settings and ensure the "baud" speed of the comport matches the device "baud" rate speed so there are no "data accidents" occurring from incompatible speeds in the data stream of things.

    My Best,

    Charles - KC8VWM
     
    Last edited: Apr 6, 2009
  4. W4DHX

    W4DHX Premium Subscriber QRZ Page

    Thanks for the quick replies, I'm using Windows XP as the OS and the computer has real serial ports. I tried using the "auto detect" in the HDR software and got the same access denied message for each com port and baud rate speed. I'm going to give the ideas you both mentioned a try -- I never tried changing the baud rate for the com ports. (Also I did purchase the Icom CI-V interface but I bought it used since the price of a new one was ridiculously high.) Thanks again
     
  5. KC2UYZ

    KC2UYZ Ham Member QRZ Page

    Are you sure you have a straight wired serial cable? A null modem cable will cause what you are experiencing. Check the pinouts on the cable.
     
  6. KC8VWM

    KC8VWM Ham Member QRZ Page

    Yeah.. The problem with the "auto detect" feature is that it usually relies on an internal database to configure external devices to work on your PC.

    The device you are attaching is "strange" to the PC ,so it doesn't know how to "auto handle it." That's why you probobly need to manually configure it instead.

    My money is on the idea that the soundcard is using the same IRQ port setting as the serial comport. So the PC is saying, "No" I am already in use by the soundcard in the computer, so no you can't use me because I am already assigned to something else. (Well at least if PC's could talk english it would probobly say that:)


    73 de Charles - KC8VWM
     
    Last edited: Apr 6, 2009
  7. AB9LZ

    AB9LZ Ham Member QRZ Page

    chmod 660 /dev/ttyS0

    wait, nevermind, you are using winders so you are screwed : (

    oh and this comment

    "The problems with comports is that all devices you attach to your serial port must match in terms of the baud rate settings and flow rates or any error correction protocals as(s)signed to them"

    isn't true, baud rates etc are set by the controlling applications and not the operating system. It sounds like an application in your startup is grabbing the logical port(s) and opening it (at the OS level and not hardware). Some kind of old malware autodialer perhaps?


    73 m/4
     
    Last edited: Apr 7, 2009
  8. ZL3GSL

    ZL3GSL Ham Member QRZ Page

    "Access denied" is a security thing. The software may be trying to access the physical serial port at the hardware level, rather than through the OS. Modern OSs (since 1970 or so) have always regarded direct "user" access to hardware as major security risks. Windows is starting to catch up with concepts like this.

    I haven't done much with XP; you ould try running the software as "Administrator". Otherwise., I'm pretty sure there are "drivers" around which avoid the security. A USB-serial adapter might contain this sort of thing in its driver.
     
  9. KC8VWM

    KC8VWM Ham Member QRZ Page

    We're not talking about Linux...

    In Windows XP, the O/S system overrides any installed software parameters and has the final say. Otherwise the installed software wouldn't be having the "denied access" issue if the software was in control.

    If the installed software says to the O/S, " Hey Windows!... I want to go at 19,200 bps on Com 1" and the comport controlled by Windows is limited to operate at a maximum speed of only 9600 bps, or if has already assigned a specific IRQ the software wants to use but Windows has decided to assign to another device ...

    Then guess what reply Windows is going come back with to the software making that request?

    ...."Error Will Robinson... Error!"

    The installed software settings don't take over and control the O/S system settings. The software can only function within the parameters specified by the operating system. It's not controlled the other way around by the installed software. (Controlling application as you put it)

    73
     
  10. KC4RAN

    KC4RAN Ham Member QRZ Page

    Blackberry / PalmOS synchronization software is notorious for grabbing COM ports. You should close every addon you can, clear your tray of everything. If that doesn't do it, run msconfig and uncheck everything that makes sense - keep it from running.
     
  11. W4DHX

    W4DHX Premium Subscriber QRZ Page

    Thanks guys for your replies. I checked everything I could think of down to the port settings, IRQ's, baud rate settings, admin rights, etc(no conflicts). I dumped any PDA, Cell phone, FAX or other programs that I thought might hold the COM ports open but still nothing. I even bought a serial to USB cable and created other COM ports....access still denied...Tried connecting up with security software turned off and uninstalled - still no go. Finally I tried hooking up the Icom interface to an old laptop I had running the same XP OS....worked on the first try. Looks like I'm going to just re-format the HD on the desk top, re-install XP and start from scratch. Thank you all again for your time!
     
  12. KC2UYZ

    KC2UYZ Ham Member QRZ Page

    One more thing you might try (maybe it was already mentioned) is to check that the BIOS has the com ports open and addressed properly. That will specifically cause the access denied error message.
     
  13. KC2UGV

    KC2UGV Ham Member QRZ Page

    Is your account you're using to do this an Admin account? It could be possible you're logging in as a Guest, or a normal user.

    You're account needs to be at least a "Power User" account.
     
  14. WA9SVD

    WA9SVD Ham Member QRZ Page

    I've seen that; you must make sure that the standard COM: ports ARE enabled in the BIOS; I've also seen such a problem if a USB port device has somehow (either deliberately or thanks to Mr. Gates) been assigned to the same COM: port.

    What USB devices do you have connected to the computer? You MAY have to disable "Punt and Pray" to assign the ports to legacy parameters.
    (Isn't Windoze in all it's flavours just GRAND?)
     
  15. AB9LZ

    AB9LZ Ham Member QRZ Page

    Odd, when I open a com1 with an app I just wrote in C# (on a winders box of course) at 9600, n,8,1, it does it just fine, if I close that port and open it with hyperterminal at 19200, it does that just fine as well... my machine must be broken. ; ) In reality, like unix, windows treats a port like a file handle, many can read, but only one holds a lock for a write.

    I.e. if I open both, one returns an access denied, depending on who won the race to grab the port and write to it. Do you have AOL or some other malware autodialer installed on that machine?

    73 m/4
     
    Last edited: Apr 7, 2009
  16. W4DHX

    W4DHX Premium Subscriber QRZ Page

    Thanks for the support guys. I ended up formatting the HD and re-installing XP. When the system came back up the problem was solved. Since the BIOS looked good before I reloaded XP, I'm thinking it may have been some program I used (cell phone or PDA) that took control of the COM ports...and didn't fully uninstall when I took it out or some malware that went undetected. In any case thanks again for the assist.
     
    Last edited: Apr 8, 2009
  17. K7JBQ

    K7JBQ Moderator QRZ Page

    While I hate to dredge up an old thread, this one speaks directly to the problem I'm having...with at twist.

    When I start HRD v.4, it recognizes my FT-890 and all is well.

    When I try v.5, I get the same error connect messages, and nothing I can do will make it work with the rig.

    LOGic8 and MixW also work perfectly.

    I thought I had a glitch witht he v.5 install, so I re-did it. Same deal.

    I've looked through the threads on the HRD boards, and haven't found a report of the same problem.

    Any ideas welcome.

    73,
    Bill
     
  18. WA4OTD

    WA4OTD XML Subscriber QRZ Page

    Try something else on that port. At least then you will know the port is ok.
     
  19. K7JBQ

    K7JBQ Moderator QRZ Page

    OTD:

    Thanks. The port works fine with HRD v4.0 and with LOGic8. HRD v.5 just won't recognize the rig.

    73,
    Bill
     
Thread Status:
Not open for further replies.

Share This Page

ad: dxeng