ad: QSKLLC-1

OS X El Capitan and unsigned drivers

Discussion in 'OS: Mac OS' started by N0FY, May 4, 2016.

ad: L-HROutlet
ad: l-rl
ad: K5AB-Elect-1
ad: Left-2
ad: MessiPaoloni-1
ad: L-MFJ
ad: Subscribe
  1. WG0R

    WG0R XML Subscriber QRZ Page


    Ok, I tried to update to El Capitan yesterday (5/27/16).

    Result: On WSJT-X, there is no signal from my Signalink, and the gain adjustment is pegged to being FULL RED all the time! As a result of this, no decoding occurs and obviously, gettin a QSO is DOA!

    I have three more states required for WAS, and am hitting this hard, so I reverted to version 10 today. The restore took about 8 hours. I recommend to anyone trying to upgrade to El Capitan to suspend the attempt until driver issues get resolved. I was on the fence for about a year about trying it out because it seemed that others had some success for a while before driver issues surfaced. In my case, the failure was instantaneous.

    I will monitor this, and other, sites for resolution for these issues, but will not make another attempt until the driver issues are fully resolved and validated.

    One question: Is anyone from Apple working with their customer engineering teams to resolve these issues? The issues have been there for close to a year, and all I get are vageries from support people saying that Apple makes the changes, and it is up to the third parties to resolve conflicts!

    WG0R
     
  2. K3DCW

    K3DCW QRZ Lifetime Member #212 Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Sorry to hear you had trouble.

    Did you unplug the SignaLink before upgrading and then plug it back in afterwards? It is always a good idea to unplug any USB device (except things like mice or keyboards) before doing an upgrade, then reconnect them afterwards. The SignaLink being a USB Audio device is fairly foolproof, although I've heard of cases where it isn't recognized as a two-channel device and thus causes issues. Solutions were mentioned in the article I linked to earlier. There are a wide variety of work-arounds and "fixes", but some will be less palatable than others. The biggest issues I've seen are with old-school (read, USB 1) devices (like the SignaLink) being run on USB 2 or USB 3 ports; especially those directly on the Mac. When I connected a Thunderbolt dock with USB3 ports and USB Audio (via the Thunderbolt dock), all issues went away. Same happened when I connected a (USB 1) Navigator to a powered USB 3 hub; all issues went away. However, each of those cost $ and required a bit of troubleshooting to figure out.

    Several developers and others that are involved in the developer and beta-testing programs are engaged with Apple at various levels, but much of that falls under NDAs and other arrangements and so isn't going to be readily evident. The USB audio issues, as addressed in that article I linked to a few posts back, extends well beyond the amateur radio community but I wouldn't hold my breath expecting a change in the USB stack, reversing the changes Apple made in El Capitan.
     
  3. LOU44100

    LOU44100 QRZ Member

    Hello guys,
    I found the drivers for ftdi devices El Capitan compatible. Finally it worked!!
    http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41
    It managed to recognize a usbtoserial bought on eBay on Chinese market. Everything works fine.
    L.
     

Share This Page