HRD and TRX with Kenwood TS870 not working

Discussion in 'Rig Control, Propagation, Cluster, & Other Softwar' started by KC3SWL, Nov 6, 2018.

ad: L-HROutlet
ad: l-rl
ad: Subscribe
ad: Left-3
ad: MessiPaoloni-1
ad: l-assoc
ad: Left-2
ad: L-MFJ
  1. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    HI
    I have tried several rig control programs and so far I can't get a single one to work. The kenwood Ts870 is connected by either a serial to usb adapter or an actual serial controller card on the pc. So far none of the programs can find the radio. I have matched port speed parity and com ports and still nothing.
    This is the usual result with all three flow control options tried at one point or another.
    upload_2018-11-6_2-29-16.png

    Has anyone got this radio to work under computer control?
     
  2. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    Just so you know I was trying various radio models to see if anything worked so I do know the ts870 is not seen in this screenshot.....
     
  3. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    Also I went into the menu to see if the rig was blocking the connection and I think I have it set for comms with pc ...according to the manual
     
  4. KA9JLM

    KA9JLM Ham Member QRZ Page

    It looks like the speed is not correct.

    Good Luck.
     
  5. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    the TS870 in the menu has speeds up to 57.6k for comm port..... so I matched that..... I even matched 38.4 on both port and radio and still nothing...
     
  6. KA9JLM

    KA9JLM Ham Member QRZ Page

    OK.

    Default looks to be 9600. 1 stop bit (96 1). You may want to give that a try.

    You may need a null modem adapter.

    Good Luck.
     
  7. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    I will try that when I get home. in the meantime I went ahead and ordered a null modem cable for the time being...... I was looking forward to having this rig controlled by the pc just like my Ten Tec RX320
     
    KA9JLM likes this.
  8. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    As a thought I tested the serial cable I had been using.It tests good using hyperterminal and jumping pins 2 and 3 I see everything I t ype. So the cable isn't defective. Leaves null modem cable to be used... bad serial controller on rig or HRD and TRZ just don't see it....
     
  9. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    Ok now this is weird. I was just fooling around with the radio and HRD and I put the serial cable NON null back in as I found in several posts related to my problem. Still no way to connect to the rig. I tried everything I could think of.Just for funs and giggles I opened up FLdigi and started to fool with that .
    In FLDIGI the hamlib tab under rig control looks like this.
    upload_2018-11-8_16-42-23.png

    Now I am seeing two things... the ctrl indicator on the radio is lit and I can tune up and down on the frequency...... HRD and TRX still are not working even though I am trying the same thing with the same settings so far as I can tell. Unless there is a hidden menu in HRD that replicates the hamlibs controlling choice.
    What is going on with with those two controllers that I can't get to work?
     

    Attached Files:

  10. KC3SWL

    KC3SWL XML Subscriber QRZ Page

    DXlabs Commander is now also working...but still no HRD or TRD I even got WSJT-X to connect to the rig but I got to learn about how to send through that.
     

Share This Page