Heil Pro 7 and Icom 7300 - No Audio

Discussion in 'Microphones, Speakers & Audio Processing' started by W5XNA, May 27, 2018.

ad: L-HROutlet
ad: l-rl
ad: l-assoc
ad: Left-3
ad: MessiPaoloni-1
ad: Subscribe
ad: L-MFJ
ad: Left-2
  1. W5XNA

    W5XNA Premium Subscriber QRZ Page

    I just unboxed and hooked up my new Heil Pro 7 headset/mic for my Icom 7300. The result - no audio. Any suggestions before I contact Heil and/or HRO? Thanks!
     
  2. W7UUU

    W7UUU QRZ Lifetime Member #133 Volunteer Moderator Life Member Platinum Subscriber QRZ Page

    Which capsule and adapter cable did you order? If using an Icom, you have to use the Heil adapter cable meant for Icom radios that has the required DC blocking capacitor.

    Read all about it here: https://heilsound.com/heil-amateur-radio/support/dsp-settings/all-things-icom/

    My guess is you don't have the correct adapter cable and/or capsule.

    Dave
    W7UUU
     
  3. SA4MDN

    SA4MDN Ham Member QRZ Page

    if your talking about headphone audio, plug the audio for the headset into a cell phone or similar and check see if you get audio that way, if you do, headset should be ok, if mic audio, no idea
     
    Last edited: May 27, 2018
  4. KB2WVO

    KB2WVO Ham Member QRZ Page

    local ham had close to same issue.... heil stated they had a bad bunch of cables or something.. they sent him new cable free..

    i would call him..
     
  5. W5XNA

    W5XNA Premium Subscriber QRZ Page

    Thanks for everyone's help. I got it figured out - operator error! 73s
     
  6. W3HXF

    W3HXF XML Subscriber QRZ Page

    I have an IC-7300 and Pro-7. No audio for ears problem. Question: do I need to plug it into a speaker jack in the back of the 7300 ? Answer message ti w3hxf@arrl.net
     
  7. KA5ROW

    KA5ROW XML Subscriber QRZ Page

    Also be aware that Icom radios supply voltage to the mike or damage could occur to the mike and the radio.
     

Share This Page

ad: NI4L-2