Fldigi on the Raspberry Pi- one hams experience

Discussion in 'Computers, Hardware, and Operating Systems' started by AG7FY, Nov 29, 2017.

ad: L-HROutlet
ad: l-rl
ad: K5AB-Elect-1
ad: Left-2
ad: Subscribe
ad: L-MFJ
ad: MessiPaoloni-1
  1. AG7FY

    AG7FY Ham Member QRZ Page

    Hello all, I’ve finally worked out all the bugs in getting my new raspberry pi 3 setup as a station computer and digital mode controller. I’ve had it running for about a week now, and I thought anyone who would like to do the same may have an easier time than I did by reading about my experience.

    I am connecting my raspberry pi to a yaesu SCU17, controlling an FTDX1200. This guide will mostly be about getting fldigi/flrig running so I hope it will be of help to everyone regardless of your interface. I haven’t gotten WSJTX talking to the radio yet so I’ll post an update when I get back to it. It installs and runs on the RasPi just fine though. So here we go:

    As we are using the Raspberry Pi in full GUI mode I highly recommend using the newest Raspberry Pi 3. I am impressed with how little system resources Fldigi uses but I think there’s still a noticeable boost over the Raspberry Pi 2 in performance. Also recommended is a class 10 SD card.

    My first struggle was with compiling the latest Fldigi from source to run on Raspbian. I have done the same on my Debian laptop, but could not meet the same success on the Pi. After solving the dependency issues from [./configure] I was then met with error after error when running [make]. So much so that I gave up and shelved the idea for a while.

    Then I discovered something that made the whole thing easy- Ubuntu MATE available for the Raspberry Pi. Fldigi and especially Flrig is still hopelessly out of date in the official repository, but thanks to the efforts of KA6MAL we have the Ubuntu-hams-ppa, a wonderful repository we can easily add to our Pi with the latest ham software; no compiling necessary.

    So we’ll start by installing Ubuntu MATE on the SD card. Direction are available here so I won’t belabor that point; but do mention if you have any trouble and I’d be happy to help.

    Once Ubuntu MATE is installed and our first user account created, we must run some updates and install the PPA from which we get our up-to-date versions of Fldigi. To do that open a terminal and run:

    sudo apt-get update && sudo apt-get upgrade -y

    This will take some time to complete on a fresh install

    Then run:
    sudo add-apt-repository ppa:ubuntu-hams-updates/ppa

    sudo apt-get update


    There is a great bunch of software in the ubuntu-hams-ppa and can be browsed from the link posted above. For now all we’re interested in can be installed with:

    sudo apt-get install fldigi flrig -y

    As far as getting the programs installed goes, that’s it! Fldigi and Flrig should run now. Now to get the Pi and Radios talking.
     
    K6CLS likes this.
  2. AG7FY

    AG7FY Ham Member QRZ Page

    The following is how I got the SCU17 to interface with Flrig, but some of the directions may help with other interfaces depending on what kind of audio drivers they need. On my laptop I had to go through installing the CP210X driver for the USB to RS232 adapter built into the SCU17, but the latest linux kernel has that already installed so there’s nothing to do there; just to check you can run:

    lsmod | grep cp210x

    to see that it has loaded. Next I had a bit of trouble getting Fldigi to send it’s audio to the right soundcard. To make that easier we need some pulseaudio libraries:

    sudo apt-get install pavucontrol pulseaudio pulseaudio-utils -y


    Once this installs, connect the SCU17 to the RasPi and radio and start Fldigi. Select 'Pulseaudio' from the soundcard options menu. The first time I did I got audio in right away, but transmissions were still trying to go out through the speaker jack. Either from the menu or the terminal launch ‘pavucontrol’. Go through the menus for input and output devices and select your sound card. For the SCU17 that will be the Texas Instruments PCM2903. If you’re radio is hooked up and receiving audio you should see the sound bar below the input selection moving. On the last menu for ‘profile’ I selected ‘Stereo output, Mono input’ but I’m not sure this changed anything.

    Hopefully you can now send and receive audio from Fldigi to the FTDX. I had one strange glitch whereby flrig somehow decided to turn the Mic Gain all the way to zero. I didn’t even know that Mic Gain had any effect on audio that was input from the sound card, but this resulted in no audio at the radio and quite a bit of head-banging by me as I was just sure there was a software/driver issue behind it. So don’t waste an hour like I did- check the mic gain on the radio if you don’t have audio out.

    Now our next steps involve getting the CAT control working between the radio and Flrig. This involved changing a few settings, both at the radio and in Flrig, from what I run with my laptop. I don’t know why the same settings don’t work, but they don’t, so here’s the new settings I found that do.

    Open Flrig and open the settings menu. Select bit rate for CAT control to: 34800. Somewhere in your radio menu should be a setting for baud rate, make sure it is set the same. On the FTDX this is menu #039. Next, on the FTDX1200, select menu #041 and set RTS to ‘disable’. This is required to be enabled on my laptop, but will cause the serial connection to the RasPi to drop. I have no idea why.

    That’s all we need on the radio, now back to Flrig. The great thing about the newest version of Flrig is the native CAT support for a lot of radios. We do not need to fuss with Hamlib for RIGCAT .xml files. Under Config >> transciever >> primary, choose the first serial port from the dropdown menu. It looks something line /dev/serial/bi-id/****. Check the box labeled ‘1’ under ‘stop bits’ and select ‘PTT via CAT’ under that.

    Under the ‘PTT’ tab, select the second serial port. PTT by RTS was selected by default on my machine, but I don’t think that matters as we’ve disabled RTS on the FTDX1200. Now click ‘Init’ in the upper right and if all goes well the Raspberry Pi should connect to the radio and have full control over all the menu buttons.

    The last thing is to go back to fldigi and open the configuration menu. Under Rig>>flrig, check the box marked ‘Enable Flrig with Fldigi as client’

    And that’s it! These settings should persist across restarts (of the programs and the Raspberry Pi). I have Fldigi set to autostart Flrig, so after the RasPi boots I double click Fldigi and Flrig comes up as well, connected to the FTDX1200.

    Well I hope that was fairly straight forward. Please let me know if there’s anything I can better clarify and report on any successes!
     
    K6CLS likes this.
  3. KA9JLM

    KA9JLM Ham Member QRZ Page

    Cool Beans. :)

    Have Fun.
     

Share This Page

ad: Alphaant-1