PDA

View Full Version : Very low RX audio on iPhone 3GS (iOS 5!)



M3ENF
10-20-2011, 02:29 PM
Hi everyone!

I've been using Echolink perfectly fine on my iPhone 3GS up until last week when I updated to iOS 5. About an hour after I updated I joined in with the usual weekly HamTwitNet. The audio level of the guys on the net was so low, it was like I was listening to a phone call not on speaker phone. The volume in the app was full to the right. I've been through every menu setting I can find within the iPhone but nothing appears to work.

Apparently when I talk my audio levels are fine as I'm getting great reports. It's just my RX audio. I've even done the "test" thing where I speak and it plays back, again my audio on play back is so low you can barely hear it.

I'm having to put the phone up to my ear like I would in a telephone conversation so I can hear people??? This was all fine before I updated to iOS 5.

Any help would be muchly appreciated, thanks...

WV1M
10-20-2011, 03:38 PM
I have the Iphone 4 with the iOS 5 update and just found the same problem.http://files.qrz.com/static/images/smilies/frown.png
I hope there is a fix, I like Echolink / Iphone
I have checked all of my other audio / streaming apps and all are working fine. I checked general settings and could not find anything that is conneted to Echolink settings.
I keep checking for an update or fix.

Thanks,

Dick
WV1M

WH2X
10-20-2011, 11:55 PM
Hello guys,

Same here after the update but I notice that if you are using Bluetooth device you can choose either use bt,
phone or speaker. You can set this at the end of the maximum volume setting there is a tab that you
can choose the option speaker note you can only choose this option only when the bt is on and connected.


73 DE WH2X

WV1M
10-21-2011, 11:22 AM
Ahhh! Well that narrows down where the bug is. It's obvious that some protocol changed from the iOS update that ignors the Echolink default speaker access. Hopefully we can get a fix soon. I have not been able to find any link to K1RFD for email to advise of the problem.

73 WV1M

K1RFD
10-21-2011, 02:04 PM
There has apparently been a change by Apple in iOS 5 with respect to audio routing for apps such as EchoLink that use the telephony audio channel, which is causing all audio to be heard through the handset instead of through the speaker.

I'm looking at the issue now and hope to be able to post a fix in the coming weeks. Thanks for your patience.

WV1M
10-24-2011, 11:29 AM
There has apparently been a change by Apple in iOS 5 with respect to audio routing for apps such as EchoLink that use the telephony audio channel, which is causing all audio to be heard through the handset instead of through the speaker.

I'm looking at the issue now and hope to be able to post a fix in the coming weeks. Thanks for your patience.


Thanks Jonathan! Just glad to see that you are aware of the problem, take your time.

Dick
WV1M

K4SFD
10-25-2011, 12:29 AM
Well, now that is good to know that I am not the only one experiencing this problem. I figured it was something to do with the upgrade because it was working just fine up to the up grade. I mean I have combed my way through the iphone and tried everything and have decided it was something in Iphone upgrade. Well please let me know when yoou have a fix. I sure do miss having the iphone via the speaker which makes it really sweet. Thanks guys for your
passing this on, now I can rest for a while. 73 de John K4SFD K4SFD@AOL.COM

W4GSR
10-25-2011, 08:03 PM
If you take a ear phone and plug it in the speaker jack.Then open echolink app go to the audio set up at the bottom right side just above the setting there is a square box tap it it will give you the oppsion for head phone or phone speaker click on phone speaker then the phone will work as before. But it has to be done every time

M3ENF
10-26-2011, 12:40 PM
Also glad I'm not the only one experiencing this and very glad to hear there might be an update soon :-)

I may just set Echolink up on my Mum's laptop to use... the only net I take part in is at 0200 local time on a Thursday morning so I can't use my PC as it's in my room and I'd wake everyone up lol... using the iPhone makes it easy to just go downstairs and take part without disturbing.

M0NKA
11-11-2011, 09:11 PM
There has apparently been a change by Apple in iOS 5 with respect to audio routing for apps such as EchoLink that use the telephony audio channel, which is causing all audio to be heard through the handset instead of through the speaker.

I'm looking at the issue now and hope to be able to post a fix in the coming weeks. Thanks for your patience.

Hello,

Just to add to the following bug. On iPhone 4S (5.0, 5.0.1) if you decide to put the phone to your ear while
you are in RX mode, this will activate Siri and will disable the Echolink App audio. Not sure if there is an API to
block Siri while in App mode.

Hope this helps.

73, Chris

M3ENF
11-12-2011, 02:16 PM
Hmm, that's interesting... that's not happened to me the two times I held the phone up to my ear. Now I'm just plugging in headphones, touching the little icon to get the sound options up and setting it to iPhone instead of the other option.

M0NKA
11-14-2011, 12:19 AM
Hi,

Could be OS bug, as i have seen it happen 1-2 times on Skype as well.

73

K6IRF
11-27-2011, 08:04 PM
Hi Guys,
I am using Iphone 4s and this morning I saw the button on the right side of the volume slider and was able to use speakerphone. That is just for a few minutes, then it was gone :) I think Jonathan is already testing it. Hope it works!
73! Lot/k6irf

KI6PSP
11-27-2011, 09:58 PM
I have an iPhone 4S also, and while attempting to use Echolink for the first time on my phone, I had a hard time because it was not using the speaker, only the headset. TX was good. I tried to hold it to my ear and Siri kicked in. For those in the same boat as me, you will have to go here:

Settings > General > Siri > Disable Raiae to Speak

This will disable Siri starting when you hold it to your ear, which is useful, but I can turn it back after Echolink.

I look forward to testing a fixed version.

KI6PSP

KD5KNR
12-04-2011, 03:03 PM
As of yesterday (Dec 03, 2011), there is now an update in the iTunes APP Store to fix the audio problem. The application now works as it did with iOS 4.


Billy Mason, KD5KNR

WH2X
12-07-2011, 01:57 AM
Hello Fellow Hams,

I just download the update on echolink iphone apps to V1.2 it resolve the audio problem on IOS 5.0.1.:)

Thanks to Jonathan for the quick update.

73 DE WH2X

ad: giga-rw