PDA

View Full Version : USB Radio Interface (URI) from DMK Eng.



K9NIB
01-10-2011, 04:50 PM
Hello All,

I have been attempting to get an AllStar Node up and running.

A device which came recommended to work with Asterisk is the URI FOB from DMK Engineering. I have this device connected to a Radius GM300.

I'm fairly certain I have the wiring correct, as when I do the 'flash' I get three transmit tones from the radio. However when testing the 'echo' I get nothing at all.

When trying to do the voice set-up, I get nothing at all.

Has anyone else worked with this device and been successful? I can't seem to find much in the way of support.

Thanks for any assistance,
Vince - K9NIB

NZ7KW
01-11-2011, 08:39 AM
Vince,

If you drop David an email at sales@dmkeng.com you will get the help you need, he has always been responsive in the past.

You might be having issues with the DSP channel number for the audio device (it is handled slightly differently from the USB GPIO device that handles COR and PTT). If your motherboard has a BIOS option to disable any internal sound device, that is your best bet.

If not, plug speakers or a headset into the internal sound card and see if the audio is on that device. You can change the device number for app/rpt in usbradio.conf (or the simpleusb.conf [I think]).

If you are linux familiar, you can also remove the sound driver for the motherboard sound device to get the URI sound device back to device id 0. Use lsmod to list loaded drivers and rmmod to remove the usb drivers. You can also rebuild your kernel without support for the motherboard sound driver or just go find the loadable driver file and delete it (usually, there are a few variables).

If you need additional help drop me a pm and I will get you contact info.

Dean

ad: giga-rw